Blender 2.8 issues

Hi,

Before filing bug reports I thought to post them here first, to check if these are really issues or maybe I’m simply doing something wrong.

The issues I’ve encountered so far are:

  • Mangled Skin modifier result

1: Add Subdivision modifier to a connected series of edges.
2: Add Skin modifier.
➔ Mangled Skin modifier result.

  • Edit Mode selection offset

➔ Selecting in Edit Mode’s vertex mode frequently gets offset. Clicking will then select a vertex somewhere else in stead of the one you click. The issue can be temporary solved by going to Object Mode and going back to Edit Mode. Maybe this is Wacom pen related?

  • Curve result completely Shrinkwrapped

I don’t know if this is a bug, but if it’s meant this way, then I really suggest to change it:

➔ When you shrinkwrap a curve that’s got thickness by using the Bevel option in the curve settings, the whole result gets shrinkwrapped, in stead of only the curve. This is inconvenient, as it’s much more useful if only the curve gets shrinkwrapped, and the bevel remains intact.

From Master tonight building for the first time for 2.8 in several months.

The following output didn’t bother me with add-on errors.

What I am curious about is how is it that an RX 480 8GB XFX Black Edition using the latest amdgpu driver on Debian Sid Linux 4.19.5 seems to be spewing to console with a completely different device driver?

location: :-1
Traceback (most recent call last):
File “/home/mdriftmeyer/Blender/Developer/blender-git/cmake-blender2.8/bin/2.80/scripts/startup/bl_ui/properties_workspace.py”, line 70, in draw
info = addon_utils.module_bl_info(addon_map[module_name])
KeyError: ‘io_scene_gltf2’

location: :-1

location: :-1
Traceback (most recent call last):
File “/home/mdriftmeyer/Blender/Developer/blender-git/cmake-blender2.8/bin/2.80/scripts/startup/bl_ui/properties_workspace.py”, line 70, in draw
info = addon_utils.module_bl_info(addon_map[module_name])
KeyError: ‘io_scene_gltf2’

location: :-1

location: :-1
Traceback (most recent call last):
File “/home/mdriftmeyer/Blender/Developer/blender-git/cmake-blender2.8/bin/2.80/scripts/startup/bl_ui/properties_workspace.py”, line 70, in draw
info = addon_utils.module_bl_info(addon_map[module_name])
KeyError: ‘io_scene_gltf2’

location: :-1

location: :-1
Traceback (most recent call last):
File “/home/mdriftmeyer/Blender/Developer/blender-git/cmake-blender2.8/bin/2.80/scripts/startup/bl_ui/properties_workspace.py”, line 70, in draw
info = addon_utils.module_bl_info(addon_map[module_name])
KeyError: ‘io_scene_gltf2’

location: :-1

location: :-1
blender: …/src/gallium/drivers/radeonsi/si_descriptors.c:1489: si_desc_reset_buffer_offset: Assertion `old_buf_va <= old_desc_va’ failed.
Aborted (core dumped)
[email protected]:~/Blender/Developer/blender-git/cmake-blender2.8/bin$

Could someone explain this reference to radeonsi when my device clearly isn’t using the RadeonSI Gallium stack seeing as there are no OpenCL Cycles devices referenced as I cannot install the recent Pro Stack from AMD as it hard requires Ubuntu, and the ROCm is a completely broken product on Debian.

You can report Skin modifier problem.
I will not say it is twisted.
It looks more like vertices added by subdivision modifier are interpreted by following skin modifier as vertices with a null radius.
In 2.79, there is probably a trick to interpolate a radius from basemesh vertices.
The trick was probably forgotten during an upgrade of modifiers.

For selection offset, verify if changing preferences can solve the issue.
In User Preferences window, go to System General Tab.
Change Selection setting from auto to OpenGL Select. Test if it is better.
Then, test OpenGL Occlusion Queries.
If none is working, report with precise info about your hardware and if it happens no matter 3D View display mode, shading and overlay settings.

About Curve result with Shrnkwrap modifier, it does not look like a bug.
By default, modifier is applied to interpolated geometry. You have to enable the last icon button in header’s row of modifier to apply modifier only on control points of spline.

1 Like

A few days ago I saw code were it only looked for “AMD Radeon RX” so it lumping all RX cards in one fix. I only looked at the bug tracker code, so, it goes way deeper than this…

I had a white screen issue so I am keeping an eye out for AMD related fixes myself. (I have a RX 560)

Use think link to find the GPU link…

https://developer.blender.org/diffusion/B/history/blender2.8/

Thanks for your help, @zeauro, much appreciated. :+1: I’ll try your suggestions.

Hi folks! First blenderartist post here!.. I am in the process of migrating from LightWave (18-year user) to Blender, and I am loving 2.8 beta, but unfortunately every gltf or glb I bring in (from Painter) makes blender crash to the desktop the very instant I click on Material button when gltf is selected. Every time… Is this common in 2.8 beta?

gltf is still being worked on but if u found a crash or a bug ,report it here and follow the guidelines…
https://developer.blender.org/maniphest/task/edit/form/2/

If I’m not mistaking, Blender 2.79b also offers LWO import. You just have to activate the add-on in the Preferences. In Blender 2.8 there’s only Newtek MDD format at the moment.

1 Like

Adding a reference image is not working for me. It is just colouring the outline of the empty. Could not find any similar reports? (Or maybe just searching for the wrong words)

Thanks. I did know that. I have actually been using blender for over a year as a middleman between LW and threejs, but not much else. I’m focusing on 2.8 right now, because I do not want to learn any of the old methods in blender… So I sure do hope that blender is going to have LWO import soon in 2.8, since I have many years worth of LWO files from hundreds of jobs sitting on my drives… :wink:

1 Like

Oh lordy. Nineteen days later and gltf/glb are still crashing Blender to the desktop the instant I click on material button, in the latest build. Anyone have any idea if this is being worked on at all? I personally would consider this a burning hot issue, since gltf is becoming the standard, and not being able to tweak materials is quite the handicap, while trying to migrate to Blender 2.8 and stick with my desired workflow. I know, I know, “experimental”“should not use for production”… But man-o-man this is frustrating because it is the only thing that is crashing Blender 2.8 for me thus far, and it is the one thing I care most about…

Hello
I try importing a high poly OBJ to Blender 2.8 beta daily build. (5GB)
Memory consumption is very high and the whole process takes 20 mins or more.
Import is not using all available cores.
1_2

2_2
2_2.jpg880x327 106 KB

Same operation in another app almost takes no time at all.

2 Likes

Okay. I got it now. Just needed to jump in to Shading. Duh…

Wow! Blender is doing a ton of work for me when I bring in my gltf/glb from Painter! Holy smokes this is nice!