Blender 2.8 keeps on crashing after I open the materials menu

I wasn’t sure where else to submit this.
Anyways, I have a problem with 2.8 crashing.
Every time I open the materials menu on the right, the program freezes for about a second and then turns off. There is no error, no nothing, it just turns off and deletes any progress. I will try re-installing Blender know and will let you know if it’s fixed.

Edit: I re-installed it and no changes, it still crashes, I will go back to 2.79 for the time being, if you have any idea on how I can fix this please reply here.

it might be worth loading factory preferences in case it’s an addon acting up, if not you could try the bug tracker.

Which OS and GPU?

Windows 8.1, image

What GPU are you using?

1 Like

This happens to me too! And i’ve been on a couple of other forums with people also having the same issue. I open blender and as soon as i click the materials button on the side, blender immediately freezes. I’m glad it’s not just me. I’m on linux. I’ve tried running blender on ubuntu 19.04 and manjaro and it freezes on both. This is with cpu rendering. Ubuntu has booting issues when nvidia graphics driver is installed.

I reported this as a bug on the blender developer site just now. We’ll see what they have to say.

You can check on the response for yourself here:
https://developer.blender.org/T68854

UPDATE: According to the developers, for blender 2.80 gpu is a must have or it doesnt work properly. You have to have a good graphics card. That’s the answer to the freezing problem!

Yes it happens to me aswell.
I assume it’s because of my unsuported graphics card.
Windows 7 and a GTX 560 with an old driver.

Seems to happen when Render Engine is set to Eevee but not when set to Workbench or Cycles though I’ve not looked into it too deeply.

I’ll wait until I have to move to Windows 10 in a few months, then take another look at 2.80.

1 Like

FYI I found a solution that worked for me! I reverted ubuntu 19.04 back to 18.04.3 LTS bionic beaver! With the bionic beaver distro i was able to install the nvidia driver and boot without any issues!! Now blender seems to working just fine. No more freezing problem!

Happens to me too. Immediate crash when I click the materials tab. I downloaded Blender 2.8 on October 28, so this has to be a recent build.

I’m using Windows 7 with a NVIDIA GeForce GT 550M graphics card.

Intel Core i5-2410M CPU @ 2.30 Ghz
64-bit Operating system

I encountered same problem, then I find a solution after watching this video with the following url : https://youtu.be/3g2yiAQaWCE

That’s not really a full solution. That’s just using Cycles instead. We still haven’t found out what GPU the original poster of the thread was using. The GPU requirements to fully use Blender is slightly higher than the base requirements to just run Blender. Basically you need a GeForce GTX 650 or higher for desktop GPU or a GeForce GT 735M or higher mobile GPU. CUDA Compute Capability 3.0 or higher in other words. Any Nvidia card that isn’t more than a decade old should be good.

You’ll notice in that “fix” video the person is rendering using Cycles on his CPU, not GPU. If your CPU is of a similar age to an unsupported GPU then I imagine that wouldn’t be a fun experience either.

https://docs.blender.org/manual/en/latest/render/cycles/gpu_rendering.html#supported-hardware

Exactly the same here. If I try to open the materials Blender immediately shuts down. I would love to at least take a glimpse into Eevee one day :astonished:

Intel Core i7-4702MQ CPU @ 2.20 GHz
8 GB RAM
NVIDIA GeForce GT 750M
Windows 8 64-bit

Cycles is not too quick on it but it works. However I never git to even see Eevee from the inside. Do I need a new computer?