Blender 2.8 Knife Tool cursor guide missing

Hey guys, I just got a new laptop with a 4K panel and for some reason the little green box that normally appears showing where the knife cut will apply is not showing up along edges or on vertices, making it very hard to see if I’m snapping to a vertex or not.

I don’t have this problem on my desktop on a 1080p panel, and I’ve tried saving my preferences out and loading them on the laptop but the issue remains, so I’m not sure it’s a preferences issue.

I don’t have issues with any other cursor, and I’ve tried setting the display to 1920*1080p to see if it was resolution specific, but the issue is still there. I’ve tried all options regarding display scaling as well as cursor size, etc. to no avail.

I’m not sure exactly what that little guide box is called so I’m having great difficulty figuring out what to google and not finding any help.

Any ideas?


All display drivers are up to date. One further difference between desktop and laptop is running a 1080ti in desktop, laptop is Radeon RX Vega M

I got the same issue on a macbook pro - didn’t even notice since I use a second monitor most of the time when modeling.

Interesting, so it shows on the external monitor but not on the laptop display?

just checked it, it’s working with older builds both on my laptop screen and external monitor, with the build from 20/5/2019 it’s broken on both.

Hmm. On my desktop running build from 23/5/19 it works, on my laptop with same build, it doesn’t.

What GPU is in your MBP, is it an AMD?

Thinking it might be an AMD related thing, since my desktop is NVIDIA

Intel iris 550 (2016 13" model, i7)

Same build working fine on linux with a 1070. It seems to be broken after the build from 15/05/2019 (8a6414ed46f6).

OK, well my laptop has intel HD 630 as well but Blender is definitely using the Vega, confirmed in graphics switcher app.

I’m stumped.

I made a bug report. might be just a setting we missed, worst case I get screamed at :slight_smile:

Interesting note, I just discovered that if I disable the Vega GPU in device manager, the green square returns. As such, functional on Intel HD 630 (horribly slow though) but missing on AMD RX Vega M GL

*Edit: Conversely, if I disable the Intel HD 630, Blender refuses entirely to launch, stating it requires an OpenGL 3.3 compatible graphics card. Bizarre.

*Edit 2: I’ve looked into it further and determined the GPU has no display connection per se, is a render only device, so will always pass through the Intel HD, which explains Blender not launching when attempting to disable it.

Not sure what’s going on, I don’t have any other GPU than my intel on my mbp. Tried it on a windows workstation with a 2080 and on another one with a 1080, both worked fine. I’ll try it on a windows laptop with both intel/nvidia cards soon, see how it goes.

edit - working fine on a windows 10 laptop with intel hd 4600/nvidia gtx880

are you using macOS?

No, I’m on Windows 10 on both desktop and laptop, same build of OS and Blender on both.

I suspect my problem is related to the AMD (Intel) drivers from this unholy union that is the i7 8705G

this has been fixed in the latest build. :slight_smile: yaaaay

Good news, thanks for filing the bug report!