Blender 2.8: NLA Editor and Baking Multiple Actions

Hey Blender Artists,

I’ve been evaluating using Blender 2.8 and Auto-Rig as a possible replacement for MotionBuilder. I’ve successfully retargeted mocap to the Auto-Rig add-on and created the necessary fixes using an additive NLA layer, but I can’t seem to figure out the process to bake them into a single corrected animation for export.

I have two NLA layers at the moment - the base animation and a fix layer. The fix layer has corrective animations being applied to the control rig. I’ve tried selecting the Rig (object mode and pose mode) and using NLA: Bake Action, but all it creates is a new action layer that doesn’t work without the original two NLA layers enabled. I was expecting all animation to be baked, frame-by-frame, to a new action. I need the corrected animation in a single action layer for export as FBX (for Unreal 4) Any ideas?


1 Like

Select all your NLA strips that you need to bake and use bake with visual keying to get a new action. Then you can either delete the old strips or make them non active in the nla. Otherwise post a blend so I can see what you actually have.

Thanks for the help stilltrying, but unfortunately it turns out that Blender 2.8’s NLA Bake is currently broken. :frowning:

Click the NLA track and then search for “bake action”
it works for me right now in 2.8, depending on your export type, you might have to bake it into 1 frame keyframes (pose+visual keying), but the default works either way.

What I mean is that the NLA track is not an action, and then when I bake it, it becomes a keyframed action. Hope that’s what you were asking and no it is not broken.

This was the scene file that I sent to Lucas (Auto-Rig creator) to look at. He was unable to get it working in 2.8, but said it worked in 2.79b. If you could, see if your workflow bakes it correctly? I am still unable to get it working in 2.8 with the NLA Bake. (3.9 MB)

resulting animation file is too large (20Mb) so I shared with iCloud

it did take a really long time to bake on my MacBook Air

Thanks for giving it a try! I downloaded the file and I was able to get this far as well, but as soon as you disable the first NLA layer, the animation breaks. The NLA Bake Action should effectively collapse the layers into a single bake animation. So when the bake is complete, the animation will be distorted until the original source actions are disabled.

I believe this is what the bug is reporting.

What? No, it only bakes the active animation (which can be multiple tracks, whatever you would get by ‘playing’ it at the time)
If you want them to be a single linear track, you should make a new track and add both actions in sequence, then bake that one. If which tracks are muted is not intuitive, you could use the ‘star’ feature to force a particular track to be baked.

You know what, I think we have two separate issues here.

I stand corrected, it does break, but not because bake action is broken. Also the brush fix is fine, I just didn’t understand it at first, sorry.

What’s wrong is the ‘rig_add’

I’m not totally sure why, but all the non-empty keyframes are added to this rig instead. Furthermore, I can’t seem to find the thing in the viewport when isolating it.

I really appreciate you taking a look at this. Coming from almost 20 years of Maya and still getting the hang of Blenders in and outs. :slight_smile: So this could be an issue with the Auto-Rig add-on?

1 Like

Your guess is as good as mine past this point, I really don’t know why. I use bake action to export NLAs to Collada format, so I know it generally works.

The problem here is baking two strips together does not seem to work anymore with Blender 2.8.
Baking one strip works, but one base strip + additive strip does not, unless we’re doing something wrong?
If anyone has a solution to this, there is just one bone, no extra “rig_add” (which by the way should not be an issue, as stated it was working in Blender 2.79):

The only way I can get actions to be combined and baked is to use the FBX export “bake” to combine the actions into one clip.

I have started to look at Blender as an option and have been told that Auto-Rig package has some good tools but trying to so some basic FK edits in the NLA system has been rough

Still exploring (and I know there are easier ways to align things now :slight_smile: after making the video but the only bake I could get to work with the FBX and then reimport the file and create a new action from it.


Wish I found this thread before I tried (I would have tried anyway).

It does seem baking two actions together is broken.

(its not, see continued discovery below)

Yes, still broken. :frowning: Unfortunately it doesn’t seem the bug has gotten much notice by the devs either. I was hoping it would have been fixed for 2.81, but I guess we will have to wait a bit longer. It’s a shame, because I am completely dead in the water for baking layered mocap onto a skeleton in 2.8.

…I found a way to make this work that I show in my latest course

But I am happy to share this here because there is a black hole of information when it comes to animation help.
Make sure you are in the NLA view, hit f3 to search and find the NLA bake action, if you run it from the NLA it seems to bake and work correctly.
The other way is to export directly to FBX (fine if you are just exporting out and want to keep a master edit) and have the FBX plugin do the bake.

1 Like

Hmm, the F3 in NLA view gave the same thing I was getting before; a bunch of keyframes, but no rotation data in them. It looks like the action baked, but the armature stays in default mode through the animation.

I wonder if I should bake the actions separately first, then bake the actions together. I’ll try that next, I guess.

My endgame is FBX export, but I still don’t like the hackiness of letting the FBX exporter determine my animations.

Make sure it is the NLA bake, and if you need to bake the bones and animation on the armature you need to select both pose and object (shift click them to pick both )

1 Like

So the trick of selecting both Pose and Object options got me a step further (wow…thought it was a toggle). But, I still have the same issue as before…its remains two tracks and I cannot merge them. They are both dependent on each other and even exporting as .fbx or using Auto-Rig’s export as FBX causes either double transformations or the corrections to not even be present.

How are you merging your multiple NLA tracks into one, baked layer?