Blender 2.8 - Not able to render using RTX 2080Ti

I just got an RTX 2080Ti a few days back and everything was running and rendering fast and fine.

Today, the problem started whenever I render, the render fails with error “CUDA Error at cuCtxCreate: Illegal address”. Sometimes it will render out a few tiles before failing. Rendering on CPU is fine. Rendering on CPU+GPU fails also.

The scene I am trying to render is the standard default startup scene for Blender 2.8 with the cube and the one camera and the one light.

Options I have tried:

  • I have tried the latest Driver for my card
  • Tried rolling back to previous versions
  • Am using the latest build for 2.8
  • Also tried other previous versions of 2.8

Could this in anyway be a hardware problem? if so, how do I make sure so that I have a valid reason to return the card for a new one?

Would really appreciate any help on this.

had a friend with a similar issue using redshift, got resolved by him doing a bios update. lowering the memory transfer rate might help as well (be careful with that though, later might have an impact on the warranty).

Thanks, will definitely try to give that a shot and see it it works.

However, since it was working yesterday I think it may be a problem with a card, after seeing many cases where the 2080ti has defective issues, mainly due to the faster memory used heating up.

Good luck! Keep us posted. I recently updated as well, keen to see how the issue get’s resolved.

1 Like

Update:
Unfortunately, updating the Bios did not solve the issue.

So I went and exchanged the 2080Ti for another brand new 2080Ti. This time, it renders for about 10-20 seconds, and after that stops and the same error pops up. I dont know if this is an issue with Blender not working well with the 2080Ti, or a problem with the 2080Ti itself.

Did you report it at https://developer.blender.org/ ?
The devs might be able to narrow down the issue or have some further insight. Did you try it with other pathtracers?

Are you sure your power supply is adequate to feed that beast?

1 Like

The first thing that I’d to is to make very sure that the proper CUDA drivers are installed, and that there’s nothing left lying-around from your old hardware that might still be confusing the issue.

The exact phrase, “illegal address,” suggests to me that the driver just caught itself doing what’s known as a “GPF = General Protection Fault” … trying to access a memory-address, perhaps on the device itself, that it can’t get to. Might there be some configuration-parameter that is now too large?

Obviously, the vendor is the first resource to turn to . . .

i have a 2080ti and i dont have this problem

Although it doesn’t sound quite the same, the first thing I check with any GPU CUDA errors is the Windows TDR setting in the registry.
Google…

BR
JN

Do you use inbuilt Denoiser? Other versions of drivers behaves the same way?
I had something similar on GTX 970, check this thread, maybe it’s the same issue: https://developer.blender.org/T58311

Checked your thread, and the below image you posted is very similar to the error I was getting where the rendering stops. Did you manage to solve it?

However, it got more serious with my whole computer freezing once it renders for 20 seconds, then after a few tries my PC crashed, and I had to get a new SSD and reinstall my OS again.

Also its not a power issue since I have a 1000W PSU.

So right now Im really dissapointed and am considering getting 2 1080Ti SLI to get the same performance as the 2080ti. I think at the moment the 2080Ti is not mature enough and there are more chances of having issues.

Kinda, but no really - I’ve just stopped using inbuilt Denoiser and switched to D-Noise https://remingtongraphics.net/tools/d-noise/

Did it help? Because I’ve completely switched whole system EXCEPT GPU itself and OS installation, so problem is definitely somewhere there. In my case I thought it’s this weird 3.5 GB of memory on my card, but looks like it’s something in driver.
This is really weird since I’m not experiencing any behavior like that in other application or render engines.
Btw, did you tried to use GPU render on 2.79b? I doesn’t have issues with it

I was going to ask the same question about the power supply - computers glitch and fail, in fancy ways when power supplies begin to fail.

I always recommend at least 850 watts when Nvidias are installed into a system.

-Will

Edit - Okay, glad to see you have 1000 watts.

1 Like

I don’t want to argue with you but I’d say it depends. I myself am running two RTX2070 with a BeQuiet 750W PSU without any problems. Or were you specifically talking about 2080s?

Well, that certainly sounds like a hardware issue (unless it’s some obscure BIOS setting etc.)

It would be good to know the exact model of your power supply as there are some pretty junky ones out there that may not live up to what’s printed on the case. I would try to get the manual for it and read it carefully and make sure there aren’t specific requirements for which connectors to use to balance the load across multiple 12V outputs etc.

As Will says, power supplies can fail in all sorts of exotic and interesting ways :slight_smile:

Update: So after running more tests yesterday, it was definitely a hardware problem with the 2080Ti, and this was confirmed with lots of artefacts showing up (space invaders)

Switched back to a 1080Ti for now, after which I still got the CUDA error, but then I followed some guides online on how to change the TDR Delay. Once I set the TDR Delay to 60, all CUDA errors are now gone and everything has been rendering fine for the past 24 hours.

I guess ill wait a few more months before getting a 2080Ti. Thanks everyone for all your help!

3 Likes

Glad to see you got it resolved.

I was considering jumping to a 2080Ti (I’m still on a GTX980 w/4Gigs), but seeing your experience, I’m thinking they may still be a bit ripe on the vine??

I’ll wait a while and keep an eye out…

-Will

Lots of people are using 2080Ti cards with Blender 2.80 (and 2.79 experimental) without problems, so I’m not sure there’s any particular reason for concern.

Thanks Gavin, I’ll see what going on later this year when I’m ready to upgrade.

-Will

1 Like