Blender 2.8 runs sluggish with Threadripper 2950X

Hey guys

I have a fairly powerfull setup up, but im not getting a very good experience with Blender 2.80. The actual rendering is very fast, but especially the interface of blender is sluggish and not snappy at all… Im running into things like:

  • switching selecting objects takes about a second
  • backstepping (ctrl z) takes more then 5 seconds in larger scenes
  • viewport response is slow
  • switch shader modes takes forever
  • bvh build is very slow (minutes)
  • cancelling a render takes minutes

Its worse in largers scenes, but also present in simpler scenes. In general, the UI responsiveness is sluggish and not snappy at all. Im wondering if it has anything to do with any of my settings in Blender…or maybe the fact that im running the latest Threadripper. I have had the same problem with 2.79 by the way…

This is my system

  • Threadripper 2950X @3.5 ghz (4.4 max)
  • 64GB RAM
  • GTX 1080Ti
  • multiple Samsung EVO SSD’s

Any help will be appreciated.

Hmm I hope this is not general problem for TR CPUs as I am getting 2990WX next week and this would be really unpleasant experience to discover… might be stupid input by me but have you tried latest version of 2.8, latest drivers for GPU, etc. by any chance ?

There has been a similar problem a bit back then (TR 1950X) and it was solved, not sure if this is related to your problem since this is about later generation but it might be.

Yeah I have the latest drivers for GPU en windows en stuff… So i dont think the problem is with that…

I read the link you send, but i couldnt figure out what the main problem/solution was for your specific case. Something with Spinlock? (dont know what that is though)

ill keep you posted when I learn more about my own issue

1 Like

And which, what kind of RAM is it?

Sorry I can’t help here but your hardware sounds exactly like mine. Except that I’m running Linux Mint 19.1.
Everything is super snappy, no sluggishness whatsoever. At work we have a similar Threadripper system with Win10 and it’s super nice, too.
Something seems to be messed up on your side. Have you tried resetting the BIOS to default?

This is the RAM that I use

G.Skill Flare X DIMM DDR4 3200 CL14 - 32GB (4 x 8GB) Black (2 packs) = 64GB

And no… i havent resetted the Bios yet. I will try this this weekend.

And @ SteffenD
I have no experience with Linux, but would I be able to install Linux on my PC so I can compare it’s performance?

Yes, you can even run it from a live DVD or USB stick without touching your existing OS.

Ah so id would bypass Windows 10 completely?
I can compare it then to my current setup and determine if the problem is Windows related in stead of hardware related… right?

Exactly. If it’s sluggish even then, you should start looking at BIOS settings or firmware updates / hardware misconfiguration.

There are some issues with windows and the TR SKU’s apparently.

1 Like

ok i think Ill try this then…can you poinrt me in the right direction about installing Linux? i have no idea how that would work… do I just download it, put it on a flashdrive and run it?

This might come handy:

1 Like