Blender 2.8 Shader Viewport

Hi all,

I’m trying to get my head around Blender 2.8. I’ve imported a model from 2.79 which used Blender Render. I’m now working with Eevee in 2.8 to add materials and textures using nodes.

For some reason I cannot see the Shader viewport! When I start a new file in 2.8 it comes up automatically. It’s only when I try and open this file that I can’t see it.

Any ideas would be much appreciated. Thanks!

Hi,afaik does EEVEE in 2.8 only support/can render Cycles materials.

If i understand you right,then your blend used Blender Internal render?

Then i would open the blend in 2.79,as you have before,and change there the materials/renderengine to cycles.then try open again in 2.8 with EEVEE.

I have opend Cycles scenes from 2.79 in 2.8 EEVEE with sucess.

hope it helps.

Use a texture coordinate node, too.

Apologies for the delay, I can confirm that saving as Cycles from 2.79 and opening in Blender 2.8 works just fine.

Nice to hear it works.You can in object mode ,append objects ect ,from older or new files to you opened file too.

here a short video how it works,very easy

The Screen Layouts / Workspaces that are active get saved in the .blend, so when you open a 2.79 file in 2.80, the UI tries to replicate the Screens you had in 2.79 as Workspaces, and doesn’t automatically give you any of the new 2.80 ones.

You can click the + at the right end of the Workspace tabs and create a new Workspace from any of the 2.80 templates, so if you’re looking for the Shading Workspace you should be able to get one that way.

Open the .blend file from the file browser (not from the recent files list) and untick the Load UI checkbox.

This will open the file with the default 2.8 UI configuration as if you started a new scene.