Blender 2.8 STL explort

Now I’ll start that I’m fully aware that 2.8 is Alpha.

Still for quite some time exporting to STL in Blender 2.8 worked, but for the past month or so, that default plugin stopped.

Did anyone hear/see any information on when export plugins will be revisited by core blender team? would this be around Beta release for the Blender Conference? or is that on back burner?

I do have a “work around” to export model in collada which does works, then import into 2.79b for any final cleanup before exporting into STL… not the cleanest and again i’m fully aware that we are in Alpha, hence above question of when?

No announcement have been made about when Python API will be released and when addons will be upgraded.

1 Like

There is some news about Python Api release?

8 posts were split to a new topic: Scaling before exporting to STL

Related somewhat: One of GSOC suggestions is to convert the STL import/export to a C module to improve the speed. Hopefully someone will pick it up. (see interoperability)

Until this morning, export to stl worked in 2.80 …0228. Not today - one file only had Collada & Alembic options.
This was caused by checking “Filter add-ons” in the Workspace panel of Properties. Even if all add-ons listed (I have four showing) are ticked, stl & obj will not be available as export options with “Filter add-ons” checked.
Hope this helps, if Blender seems to get picky about whether it will export stl files.

Thanks for that. I know there was some discussion around saving memory by only loading Add-Ons in the workspaces you are using them in. (Don’t need Loop Tools during Compositing for instance)
This might be related to that. If you are having export problems, try switching workspace and see if it’s available again.

I’ve just tried that. No difference after switching. If Filter is checked, stl and obj export is gone from the File menu.
Can still be done from the 3D printing tab, though, but that’s a bit odd in the way it’s “presented” to the user.
The stl export add-on doesn’t work, Filter or not. The built-in stl export has to have Selection only checked, or everything is exported. There’s a “lib” file that can be changed from “False” to “True”, but not worth doing until the 2.80 stable release.

The dimensions part is still kinda busted: it doesn’t takes into account the scene units and still needs the 1000 multiplier to keep the dimensions

I keep seeing this problem with 3D Printing too.
As STL is dimension agnostic, and CURA assumes that 1 Unit = 1mm and Blender (in metric) takes 1 unit = 1m everything will always be 1000x times too small !
I have kind of gotten used to using the scale in the STL Export to compensate, but I wish the same scale multiplier was available in the 3D Print toolkit tab for its export.

I haven’t had that problem. Blender 2.8 is set to millimetres, and I export stls via the File menu.
I have also edited the Blender io_mesh_stl/ file to export [selection only] as default (not that this affects dimensions).

I also experienced various inconveniences with exports and imports. I had to write an add-on for a clearer organization of the export and import workflow with presets. Multi Exporter

1 Like

Hello Alex,
Since I’m new to Blender, - but now new to 3D-printing -, it is perhaps a stupid question in this whole conversation but …

  • Does your Multi Exporter gets rid of the scaling-trouble ?
    I mean:
  • When I created an object of let’s say 60 x 110 x 30 mm and I let your ME export it to an STL-file … can it be loaded into a slicer and have indeed the same measurements ?
    Best Regards,

It all depends on your own ‘Units’ settings in the blender. Addon ‘ME’ exports with standard export options blender.

Standard export options:

The only difference is that when exporting through the ‘ME’ addon, you can specify the ‘Use selection’

In the next version, the ability to save and change user settings will be implemented.

1 Like

Thanks Alex, for the elaborate explanation :wink:
That’s very helpful for a newbie like me !
By the way - PayPal on your website does not work properly because it keeps asking for a creditcard although there’s enough on my account.

Please try again later. Perhaps these are some technical problems on the PayPal site. If you can not make a purchase write me a personal message.