Blender 2.8 Viewport Performance

(noki paike) #315

no never, at best ironic :grin:

0 Likes

#316

Well we got some comments about it, make sure you dont cross the line :stuck_out_tongue:

0 Likes

(noki paike) #317

yes, don’t worry, I’m well aware of being under observation and therefore being able to be shot at any moment
:joy:

0 Likes

#318

Im not observing you directly, two of our community members raised concerns, prompting me to get involved :slight_smile:

1 Like

(noki paike) #319

I’m used to this, in my whole life, before they perceive me grumpy or presumptuous, because they think I attack their ego, then when they realize that I’m only interested in the best results and the best efficiency and then they become best friends

0 Likes

2.8 viewport performance
(Steffen Dünner) #320

Just found this by Sergey:

Multires: Make topology cache to work with copy-on-write
https://developer.blender.org/rB4f26d2348c41d6c7b9d32d3b8372a6253750fc22

Maybe this is of interest for some people here…

2 Likes

(Ace Dragon) #321

Clement has been working on optimizing the CPU-related code in the draw engine.

No multithreading yet, but a couple of so-called “hotspots” taking up CPU time were addressed.
https://developer.blender.org/rBfefc9c95e4818768ba08c665111d2e405ae72672
https://developer.blender.org/rBf12040e088b66748340b0d7472d1155596e0f9e2

12 Likes

#322

Since i switch from 3ds max this is one feature i am truly missing fast viewport with heavy scenes but hey can’t complain for the price!

1 Like

(dan) #323

fingers crossed https://developer.blender.org/T57936

6 Likes

(• I don't speak English "by default", so... ) #324

It’s funny, but if you disable overlays, the performance in edit mode increases a bit lol…

0 Likes

(gsz) #325

I noticed that performance drastically falls when i turn on manipulators - transform, rotate, scale.
When scene is “clear” i mean when I use only select tool - everything is ok, but after manipulator appearance further work is a tragedy

My workstation
Intel Core i7-8700- 3,20 GHZ
RAM : 32
GPU - GeForce GTX 1070 Ti

0 Likes

(Zinogg) #326

man ,i do hope they improve performance in edit mode drastically…right now 3ds max is the only one that i have seen that can handle easily up to 2 millions polys with no slow downs, just on a mid-range machine… i can only imagine what’s like on a high-end, surprisingly blender 2.80b is much better than maya in both edit/UV modes , i tested between 100k to 300k polys, and i had to wait for longer seconds to move few chunks…

1 Like

(filiuspatris) #327

Like this?
https://developer.blender.org/T61474

0 Likes

(Metin Seven) #328

I have to add ZBrush, able to handle tens of millions of polygons without significant slowdowns, using an approach that doesn’t require the whole scene to be redrawn with every little event.

4 Likes

(gsz) #329

yup. exactly.

0 Likes

(Ace Dragon) #330

That is on the todo list fortunately, with the goal to at least get it back to 2.79 level (which applies to subsurf as well).

If they can get it faster though, that would be great. 2.8 can then be seen as improving performance in literally every area.

2 Likes

(JTenebrous) #331

(Skip to the bottom to see the resolution to the issue raised in this post)

Can anybody help to shed light on why 2.8 beta viewport performance, in Object Mode, appears to have severely tanked over the last two months? I won’t waste too much time with the backstory, but I was working heavily in Blender 2.8 around Jan/Feb 2019, but only lightly through March. Now I’ve got another big project, and today I went to open up a Blender scene I had saved in February 2019… but I opened it with the latest 17Apr19 build. The viewport performance is just miles below where it was in my last build, dated 28Jan2019. My scene has a 2 million triangle .STL file in it (yes, this sort of thing is a regular occurence in my job), but I’m not expecting to do any Edit mode things with it… it just needs to “be there” for now. In the 28Jan2019 build of Blender 2.8 beta, my viewport doesn’t skip a beat with this 2M poly object present in the scene in Object mode… it’s very fast and responsive. When I load the same scene in the 17Apr2019 build… absolute stutter fest. Even if the object is de-selected, it causes the UI to slow to single-digit framerates. You can actually see UI elements take upwards of 1 second to highlight when the mouse passes over them. Out of curiousity, I tried a few other Blender 2.8beta builds from the last few months: 28Feb2019, and 05Apr2019… both of these builds have slowed viewports as well. What happened? It was great in late January, and it’s very poor now in April… no preference settings or computer hardware have changed. Any idea what gives?


Edit: (5 Minutes Later) Perhaps I spoke too soon. After a bit of additional troubleshooting, I decided to freshly import the 2M triangle STL asset into a new scene created in today’s (17Apr19) build of Blender, instead of working from the files I had created in older builds. This appears to have improved Object Mode performance drastically when viewing and navigating around this heavy mesh. There are no other differences between the freshly-rebuilt scene and the original one saved in the 28Jan2019 build, so I can only assume the performance differences come down to some major under-the-hood updates to save files that have occurred in the last two months. In other words… typical “beta” stuff. I just thought I’d better update my post to give the full story.

1 Like

#332

Agree it’s a pain and my workflow is to detach my mesh in multiple parts and re attach when local editing is done while in 3ds max i have no need to do this.

0 Likes

(Zinogg) #333

well zbrush is a bit unique in it’s drawing techniques and using 2.5d gives it more power to handle millions of polygons…but if we can get something like that, that would be a dream come true.

3 Likes

(Thinking Polygons) #334

Zbrush works in 3D. Zbrush is only Pixols (2.5D) when you’re not in edit mode.

1 Like