Blender 2.8 viewport updates

I hope yes, because it’s really something important IMO.


Viewport’s status bar brightness issue was finally fixed… :wink:

1 Like

I was wandering about smoke simulation, at the moment it doesn’t work at all I think, but it used to work for a bit in Blender 2.8 and EEVEE, and the visualisation used the same type of tech than the “volume world” I guess (tell me if I am wrong here). And when I see the previs of smoke sim in Blender 2.79, it is pretty good, is their a reason why we can’t have the same type with EEVEE ?

EEVEE should give a result better than 2.79 previz.
You will be able to use same principled volume shader for EEVEE and Cycles Render.

Currently, there is no density and other smoke attribute useable by the shader. Simulation is not working, not able to bake them. It is the only reason why you can’t render a smoke simulation with EEVEE.
But volume objects can be rendered by EEVEE with transmittance and shadows.

Just be patient. Workbench should be able to display heavy simulation and OpenVDB assets.
If they are too heavy with a high resolution, maybe, it will be complicated for EEVEE.
But EEVEE would probably be able to give an approximate result.
Maybe OpenGL render will have also its own limitation, too.

The reason why it is not working, now, is probably a work in progress on OpenVDB grids (that are ugly in 2.79).
OpenVDB primitive from this year GSOC will use that. And mantaflow branch should use that, too.
So, you could wait to know what 2.8 previz will look like before asking one similar to 2.79.

Two changes and one option to have a clear distinction between Edge Select and Face Select mode

Thicker edges

Ability to show faces dots when “limit to visible” option is enabled.

Now, you are sure to distinguish Edges mode from Faces mode.
Face center is an overlay option that can be disabled.
I don’t know if people will like thicker edges. It is not an overlay.


Has anyone noticed that T and N panels now fade in this kind of very slow, ugly, low framerate fade animation? Blender overall is always snappy, but this low framerate fading animation makes it feel quite slow and laggy :confused:


Yeah, i don’t like it
We need performance boost not a pretty FX on UI

1 Like

Indeed, I hope we can remove the fading effect.


Just clear things out, are there any plans for bump map aliasing issue? That’s the biggest showstoper for me to use eevee in production aside of DOF. I would realy appreciate any info.

If you turn off “Region Overlap” the fade effect goes away.

Personally I don’t mind the fade effect, it opens almost instantly and doesn’t change the speed of operation… also doesn’t look low framerate to me…

So :neutral_face:

And by the way, this effect also exists in 2.79…

1 Like

Really? It does for me on W10 and GTX1080Ti. Would you be able to record 60FPS video using something like OBS and upload it on youtube?

Also, given that you are a long time Blender user, I am sure it’s more than obvious to you that disabling region overlap is absolutely not an option, especially in 2.8 where entire look of the theme relies on it (to not look ugly).

EDIT: Here, I’ve recorded video of my 2.8 at 60FPS. You can clearly see that while other UI element animations and movements happen at very smooth 60 FPS, the panel fades at what appears to be 10-15FPS, making it feel really laggy and ugly. The fact that Surrounding UI elements rearrange at the end of the fade, not at its start further amplify the feeling of lag and choppiness:

EDIT2: Unfortunately it’s a bit harder to see with the compression. Without it, it’s clearly possible to see kind of low framerate brightness flickering as the panel appears. In compressed video it looks smoother than it really is.

It looks like Clément have on his todo list as high priority addition of an option to improve depthbuffer for all screenspace effects.
He listed several tasks related to AO and unsupported nodes. He will probably try to solve both : AO, bump and normal maps problems at same time.

Don’t know what you’re seeing, but here things looks smooth… Can’t make a video, sorry…
And for the record, I think blender looks/behaves better with region overlap off, but most people will never agree with me.

1 Like

Thanx for the reply. Glad to know it will be solved. Right now rendering at 200% seems to be good workaround.

I do agree with you, at least there’s nothing blocking the view when region overlap is off.

1 Like

What’s the point of the “thicker edges”? It was okay before.

Being able to distinguish combination of several modes.
Vertex Dots+ Faces Dots -> Face and Vertex select modes are active.
Thicker edges + Face Dots -> Face + Edge select modes are active.
Vertex Dots + Thicker Edges +Face Dots -> every component is selectable.

Same thickness of edges + no face dot -> What is active ? Face mode ? Edge mode ? Edge + Face modes ?

Personally I don’t care about that visual distinction, as I never needed this on other 3d apps, but if people love it, then so be it. I just wish it was an overlay option, so I could turn that off.

Well, the way I read things here. Blender 2.8 is kind of laggy and slow right now in multiple areas (so no surprise).

The way Blender development has generally worked is that optimization comes after all of the major pieces are in place. Like with Cycles, everything should get faster eventually with the likes of Campbell, Brecht, and Sergey as core developers.

I don’t see what you mean by low framerate, but I do agree the animation is way too slow. I’d shorten it to some 30 ms so it doesn’t take more than 4 or 5 frames (at 144hz).