Blender 2.82 requirements

My old laptop had quite a few issues … it was about 12 years old… so I bought a new laptop
HP 15T-CS200
it has intel i7-8565U 1.80GHZ Quad core processor
NVIDIA GeForce MX250 with up to 4GB discrete video Memory
16GB Ram they have 2 drives in it… one called Windows with 91.2GB free and one called Data with 910GB free
I’m trying to run Blender 2.82 and I tried 2.81… I can model something without a problem… working good… but when I try to add material/texture to the object, Blender freezes and then the computer crashes…
Is my Video card not good to run Blender??

thanks

It is good enough

do You have newest drivers? for both integrated GPU (in i7-8565U) and GeForce MX250?

mhm, thats disturbing

As far as I know it does… I ordered it on 4/3 and It was just built for me and I received it on 4/24/20… I will do a driver update on Device manager and see if it updates it… All the drivers on HP website are showing 2019… I can work on anything else, play games, etc… the only time it freezes up and crashes is when I’m trying to put on Textures in Blender… I work usually with Blender every day for anywhere from 2 to 6 hours a day…
My drivers are from November 2019 for both of them and the HP website drivers are from Feb and Mar 2019… So I do have the newest drivers I can see

If You right-click on blender do You have option like “run with graphic-processor …” ?

Does it freezes right away when you enable material mode or there is lag? Does it does that every time or sometimes?
What shows after crash?

Could you paste here system info from Blender (Help>system info)

If I am modeling something in Blender it is okay… When I start adding the texture to it, is when it freezes and then shuts down the computer in about 2 minutes after it freezes… I tried Blender 2.80 and it allowed me to add about 3 textures to 3 items… when i tried the 4th item, as soon as I clicked “Open” in the Image Texture node, it froze up… In Blender 2.82, it freezes when I try to get the first texture. When I right click Blender, it does have the option to "run with Graphic Processor…
I created the system info for Blender… It is long… do you want me to copy and paste it or attach the file

thanks for checking it for me… I do love working with blender and this has frustrated me… I’ve been using blender for quite a while learning how to model …

system-info.txt (25.6 KB)

I right click Blender, it does have the option to "run with Graphic Processor…

okay, so
try to run in by the other one GPU
obraz
go Integrated graphics

and chack if crashing persist
if not problem is probably on MX250 GPU hardware or drivers side

if it stops crashing you can try downloading newest drivers for Your GPU from iNvidia’s site

renderer: ‘GeForce MX250/PCIe/SSE2’
vendor: ‘NVIDIA Corporation’
version: ‘4.5.0 NVIDIA 441.45’

it says You have 441.45 drivers, and are: Version: 445.87
https://www.nvidia.pl/Download/driverResults.aspx/159563/
You can try installing it.

Okay. Will try that and see what happens… so Nvidia has a newer driver for mine… everything I was looking at was not as new as the one I had…
will check it out… and let you know

appreciate your help… God bless you

I opened Blender 2.80 with integrated graphics… (which says it is default.) it froze up when I started putting on the texture… I started the computer back up and this time loaded it as High Performance Nvidia processor
(mine shows as Integrated graphics (default) or High Performance Nvidia processor)
I loaded a new texture and assigned to the area to be textured, did a UV unwrap and the blender just closed down… It didn’t freeze up this time… just shut down… I have downloaded the 445.87 version release date of 4/15/2020 … Is this the one I need to install? Hopefully will work okay

thanks

Is you graphics card showing up properly in Blender’s preferences? Under System? Is this in both EEVEE and Cycles and have you set Cycles to use CPU or GPU?

Have you tried opening up Windows Event Viewer after these crashes to see if you can identify any issues there?

In Blender’s preferences under System, It shows under CUDA GeForce MX250 and it has a check in the box…
under OpenCL, it says No compatible GPUs found for Path tracing
Cycles will render on CPU
which is how I’ve been rendering Blender ever since I started using blender…
Under the Render tab, In Cycles, it does say CPU nothing under Eevee
All I can see in the Event Viewer is that it was an unexpected shutdown (listed as an error)
then I see a warning
“The driver\driver\Wudfrd failed to load for device PCI” and a lot of numbers after it
and another warning "The driver\driver\Wudfrd failed to load for device " and other numbers after it…

I know a little about computers but not that much…

Yes.
did it helped?

hmm, so some kind of problem with drivers

btw on what render engine do You have crash?
obraz
Green: Workbench
Red: EEVEE
Blue: Depends on what engine is selected in Render Properties

I usually have it in Cycles…
I have been dealing with Microsoft… they told me to roll back the driver to the previous one.
I tried that and with the previous driver for the NVIDIA GeForce, after opening Blender, in 2 minutes it would just close down…
I upgraded to that 445.87 version of NVIDIA and doesn’t help… Blender as soon as I open it, it freezes up

 I'm stumped as to what to do to get blender working again for me...  and so frustrated at this point..  I guess If i want to work on blender I will have to use Blender 2.79B and won't be able to use Blender 2.82 unless someone has a solution for me... 
 HOW do I open a 2.82 file into 2.79B so i can work on it in it??

can you run blender with argument --debug-all ?

so on intel lt just crashes blender, and on nvidia it crashes whole system?
is it only with particular images or any?

its hard to help with hardware/drivers problem through internet :s

How do I run blender with argument-debug-all? sorry… I never heard that before

thanks

Use [Windows]+[R] to open “run” menu, type “cmd” and pres ok
obraz

paste

cd c:/Program Files/“Blender Foundation”/Blender 2.82

and type
blender --debug-all
or blender --debug-gpu

Enter

now try to crash blender
it may print some important data

the problem is that You have hardware/drivers and not blender itself so it crashes windows
i dont know how to read that messages and i’m not sure if it will be helpful at all

have You tried to instal/update once again all the drivers?

or disable that:

I ran a diagnostic of the hardware and everything passes as okay… my GeForce MX250 has the newest drivers and the Intel UHD Grpahics 620 was updated… In the old laptop there was no option to run blender with graphics processor yet in this laptop the option exists… WHY the difference… Also under CUDA in the old laptop, it only says "No compatible GPUs found for path tracing, Cycles will render on CPU… " In the new laptop, under CUDA it has a check mark next to Nvidia GeForce MX250 and the message “No compatible GPUs found for path tracing, Cycles will render on CPU” is under the opencl … the graphics in the old laptop was AMD A8-4500 APU with Radeon HD graphics
in old laptop Blender 2.82 worked fine with no issues… but in new laptop it crashes… I turned off the Link State Power management when plugged in… I uninstalled Blender and made sure I deleted all folders of Blender 2.82… then reinstalled and i went into Blender 2.82… I put texture onto a few places, rendered it and it didn’t crash … so far… fingers are crossed… If it crashes again… I will run the debug thing to see what it says… I will use Blender 2.82 tomorrow and see how it goes… I will let you know after I enter some texture into it tomorrow, how it went…
thanks so much for all your help… I hope this has helped and it’s now going to work… but I’m not holding my breath yet…
:slight_smile:

What I do know:

  1. CUDA is for NVIDIA technology, been here for many many years.
    So it is very OK to see your GPU there.


    Those who have anything other than NVIDIA will see nothing here.

  2. OptiX is also for NVIDIA GPU but is only for RTX series -> than can give a boost on materials like water, mirros, glass, metals etc.

I have a GTX 1050 so I see this: (and is normal, because is a GTX and not RTX. You have GeForce that is even more low… )

  1. Open CL is AMD GPU (so is something for people with AMD and Apple products to be able to get a boost from their PRO LINE of GPU. Domestic AMD GPU does not show here)

I have Nvidia GTX 1050 so of course says that no GPU found

It very OK that Blender see the GPU and the CPU.
Why Blender 2.8 does not work on your computer with MX250 well maybe because there is a conflict of drivers…
Games are one thing, Blender is another thing.
Also Blender 2.8x is another beast than 2.7x…

Here you can find benchmarks on Blender (official)


There is entry on MX250 -> 8 benchmarks in total with a score of 554 points.

Gorion103 Zuorion
Thank you ever so much for your help… I’ve been stressing with it for a week. Changing the PCI Express/Link State Power Management to OFF for Plugged in: helped…
I set up a quick house, added siding texture to it, roofing texture and chimney texture and NO crashes… God bless you … I am grateful for you taking the time to help me solve my problem… I can now work with my Blender 2.82 again… thank you - thank you… Hopefully no more crashes…
have wonderful day…

WELL, it worked for a while… then it started crashing again… I ran the debug for Blender… I did the Blender --debug-all
I don’t know what it is telling me… Here is the file if you understand what it says… BLENDER BUG RUN.txt (14.0 KB)

thanks