Blender 2.82 - ShrinkWrap Not Rendering, Disable in Render Issues: Cycles

First time working in blender 2.8+

Currently working on a model that has an object that is being shrink wrapped to a sphere. The object is being deformed by a plane with Shrinkwrap and solidify (in that order). Everything works perfectly fine. In the viewport, I can go to render preview, and I have everything posed and ready to go; however, as soon as I try and actually render, problems arise.

  1. If I disable the deformation plane rendering visibility, everything renders, but the shrinkwrap modification does not take place.

  2. If I toggle it to be visible in rendering, the deformation takes place; however, the the deformation plane is visible. I tried making a transparent shader, and it STILL renders with some white texture.

None of the modifiers are applied, as I am exporting keyframes for reference, and in the past, this has worked flawlessly on older versions of blender. Has a setting changed?

Unfortunately, I cannot share the blend file, as it is for someone else.

After having wasted 4 hours on this problem. It appears to have been fixed by me moving the subdivision modifier’s render quality on one object. Worked perfectly fine after that, and I just moved it back to the quality I was originally trying to export.

Not sure where I should report this as a bug.


Never mind. It worked once, and the rest of the exports arent working anymore.

Ok. Quick fix, as it has been repeatable: Take subdivision off and back on. Not sure what is going on here.