Blender-2.83/2.82a (Linux) , Nvidia RTX 2060 SUPER => no Optix?


following system:
GENTOO Linux (64bit), updated on daily basis
NVidia RTX 2060 Super

The RTX 2060 SUPER is recognized by Blender as CUDA capable.
But the tab “Optix” shows “No compatible GPUs found”.

Why is that and how can I fix it?
Thanks a lot for any help in advance!

Are you using official Blender build?

You share the output of each of these commands here:
lspci | grep -iE 'vga|3D'

cat /proc/driver/nvidia/version


I think you need to install also other packages like and things like that on your system. I saw a list (that I don’t remember where sorry) a while ago telling what you need to install to use Optix… I think it works also for Linux but I am not sure. Note: I am using Optix one Windows 10, it is really worth the effort believe me.

@tuxic, Before installing the SDK (this should not be necessary, at least this was not necessary on my Kubuntu Linux), you try the official Blender 2.83 link that I shared above.
If this still doesn’t work, you open the terminal where 2.83 blender executable is and you open blender with the following command:


Hi Yafur,

thanks for yor posting! :slight_smile:

Yes, I use the prebuild binaries downloaded from the sites you linked. None works so far.

The output of the command
lspci | grep -iE 'vga|3D'
26:00.0 VGA compatible controller: NVIDIA Corporation TU106 [GeForce RTX 2060 SUPER] (rev a1)

The output of the command
cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 440.64 Fri Feb 21 01:17:26 UTC 2020
GCC version: gcc version 9.3.0 (Gentoo 9.3.0 p1)



Thanks for your posting! :slight_smile:

You need to register with the “NVIDIA Developer Program Membership” for getting that download.
I don’t think, Nvidia wants every Optix-using Blender-Enthusiast becoming a “not-developing” developer
for their program…
But will try that …

Hi Yafu


tried that…it does not work for me.
What graphics card you use?

Would it be possible, that I got a “fake nvidia” card?


Supposedly you just need to have the nvidia driver properly installed, as long as we use official Blender, which contains precompiled kernels.
Maybe there is an extra driver package in Gentoo that incorporates Optix support? (you could ask this in Gentoo forum)

In Ubuntu the nvidia driver installs “libnvidia-compute” package containing runtime libraries needed for CUDA, OpenCL. And “libnvidia-gl” package that contains a library called “”. Please you ask in Gentoo forum. It would really be tedious having to install things downloaded from nvidia site to achieve this. It should be necessary only installing nvidia driver if it has been well packaged by the distro.

I don’t even have an RTX card (GTX 960). I have to launch blender in compatibility mode with “CYCLES_OPTIX_TEST=1 ./blender”, and then I can have Optix on GTX card. This works correctly.

Thanks! Yes I did register. In fact I think Nvidia also wants to see interest in their Optix solution. It is not exactly that we are using the SDK, but there are some drivers that need to be installed for Optix that Blender uses (I am not on my computer now, so I cant check what I did install or not, I did try to compile the blender with optix before it came in the official versions so I remember I read quite a few pages about the subject a while back) Keep trying, if it doesn’t work I’ll help you further.

I am interested to know if using Optix on such a card is a benefit , is it faster than Cycles or you use Optix for some other reason?

Optix AI Denoising. It is very convenient, especially for Viewport Denoising.

1 Like

Yes indeed, great, amazing. Thanks

Hi Yafu,

the nvidia-drivers are closed source and therefore it is not allowed to alter the contents (remove something or change something). Gentoo just fetches the binaries and install them into the system (everything else, which comes as source is compiled on the system in question, though)

!BUT! :slight_smile:
Neither libnividia-compute nor libnivia-gl are installed here.
I think (read: don’t know for sure) that these are part of another package (not the nvidia-driver one).
Part of what package (Ubuntu-wise) they are? (sounds a little bit like Yoda-speak it is :wink: )
I will then try (as an experiment) to install that Ubuntu packages on my Gentoo system and check,
whether this will help…

Ah! By the way: What is “blender compatibility mode” ? How can I switch that on? …and to what blender is
compatible then?

Stay healthy!

Package maintainers are allowed to organize nvidia libraries into different packages. In addition maintainers generally add different installation scripts for each distro. For example these are the packages in Ubuntu:

No, those things generally don’t work out well. I mentioned these packages to you so you can tell about they to Gentoo maintainers on the official Gentoo forum (if it exists).
It would be good if Gentoo maintainers know about your problem.

There are some environment variable to allow testing on Blender unsupported hardware. One of them is this for Optix that I have already mentioned, launching blender with " CYCLES_OPTIX_TEST=1 ./blender"


ok, I finally managed to get it running.

I will mention the solution here despite it is more GENTOO specific, but may be I am not the only one using Blender on GENTOO Linux - then it may be of help to others, too.

You don’t need to install the Optix SDK nor anything else other than the nvidia-drivers.

GENTOO does change the contents, which get installed into the system. Do to a feature/bug in the ebuild for the nvidia-drivers, these libraries only get installed, if AMD64 and MULTILIB USE-flags are installed.
You can set MULTILIB for the nvidia-drivers only. This flag is normally used in systems, which support
32 bit and 64 bit binaries. In this case it is kind of superflous, since the libraries are 64 bit only.

The missing libraries are:***
The according version of the driver package in question is appended to the filenames of the libraries.

Presumeable because I am on a 64 bit-only system I couldn’t set MULTILIB.

A simply workaround is to get the nvidia-driver package of the same version which got installed on the system from NVidia.
Then unpack and skip the installation of the package with the following command (here for the version
440.64 of the driver):
./ --no-x-check -x
which creates a directory NVIDIA-Linux-x86_64-440.64 with the contents of that package.
Then copy the libraries mentioned above to /usr/lib64/. and do a ldconfig afterwards - both as root.
You do not need to stop X for that, but you should terminate blender in advance.

This is a workaround. This is not a “clean way” to get Optix working.
When the drivers get updated via emerge, you need to remove the three libraries by hand – if the feature/bug has not been fixed in the ebuild.

SInce the nvidia-drivers are the same on any Linux system, this should work on other Linux distros
in an adopted way.

Thanks to all who helped me to find this workaround! :slight_smile:
Stay healthy !

Good to know that you have solved it.

I hope you report the issue to Gentoo maintainers.