BLENDER 2.83 (2.90) unstable & corrupting files on MacOS! Anybody else got this?

My friends, my deep love for Blender is going through some tough times recently.
I’ve been using blender since 2.8 Alpha. (On MacOS)
And all the versions I used, even Alpha and Beta versions were super stable. Which really impressed me.

Now this all changed completely with 2.83, all versions so far, (and 2.90 Alpha). Now I got more recent crashes.
But those would not bother me much, since I’m a super frequent saver.

What really bothers me is, that Blender starts to corrupt files (only in 2.90 Alpha). Sometimes it’s a collection which I can’t touch anymore - or Blender crashes.
Once a project crashed and then would instantly crash on every reload. Even when trying to append the collections into a new project file Blender instantly crashes.
Then I have objects which do not show after appending.
All things I have never experienced in earlier versions of Blender.

The problem is, these issues are very difficult to recreate. They seem random. It’s possible a collection got corrupted by simply renaming it. I also noticed some sort of memory leak. Projects growing to Pib sizes. (Which can be helped by restarting the project.)
But I have no idea what caused all the other issues.
And before I start to try to figure that out (which will be very time consuming) or file a bug report, I wanted to ask if anyone of you has experienced similar issues with 2.83 on Mac.

I have to add, that at a similar time I upgraded to MacOS Catalina. But I can’t imagine that the MacOs is corrupting files in Blender.

Did any of you experience similar issues?

Btw, I’m currently using Blender 2.83.2 on MacBook Pro 16" (64GB Ram, MacOs Catalina 10.15.5)

Really? No other Mac user has stability issues with 2.83 and/or 2.90?
Oh man…I envy you, guys! :wink:

If 2.83 and 2.90 runs very stable on a Mac - could you tell me what OS you’re using?

All I can add is that I did have issues with corrupted files in another application (Affinity Photo). I pestered the developers for months with every new beta release.

Turned out my volume/disk had some errors on it, all fixed after running diskutil. Perhaps that’s your issue if the corrupted collections etc don’t turn bad within a live session but after loading a saved (corrupted) file?

Thanks for answering Thomas.

My issues happen on a brand new Macbook Pro 16"
OS, applications, addons - all are freshly installed.
That’s why the issues are even more surprising.

It’s the first time I’m using Blender on Catalina, though. That might be a cause.
(Before I used Blender on HighSierra and Mojave, on an iMacPro.)
Therefor it would be great to hear if other Mac/Catalina users experience similar issues.

Apart of corrupted files in 2.90 I have quite a lot of crashes with 2.83. But with lot’s of different causes. While rendering (particles). While setting up smoke sims. And very often I don’t recall what the last action was before a crash. They happen so randomly. Smoke surely seems to pose a problem though.

I read about other people having issues with 2.90 somewhere else, but can’t find that post/forum anymore…

New computers don’t mean the drive can’t have errors. There is still a failure rate in brand new hardware. You should check your disk.

1 Like

Corrupted files in alpha and beta versions are to be expected. I have never had them in a beta but it happens sometimes in alpha versions.

This should not happen in a stable verision, though such as 2.83.

I checked my drive. All fine. :wink:

Catalina 10.15.5, Blender 2.83.0, no problem as of now.

Corrupted files I only had with the 2.90 alpha.
I was still surprised, cause I used all alphas since 2.80 alpha - and they were always super stable. But of course, as you mentioned, this can’t be expected.

2.83 (latest version) did not corrupt any files. But it crashes a lot more than any of the versions before did. Alphas and betas included. So I wondered if that only happens on my Mac…

Thanks Kabu, for letting me know.
Did you use smoke, particles and/or physics sims… without any crashes?

Ah, I see. Yes, I also usually do not have any corrupting problems with alphas and betas but I did have problems with an alpha in January 2020 with corrupting the files. It didn’t crash but it seemingly randomly refused to save some objects, so when I reloaded the file some of the objects were simply gone. I can’t remember which alpha that was, though. Might also have been the experimental functions branch.

As for 2.83 I have not any any problems on Windows or Linux regarding crashes. The only thing I notice is that it turns objects reddish with viewport shading to solid and color to random if I undo a bunch of times. I do not know how to reproduce this, though, so I don’t know ho to file a bug report.

No, I’ve got an old mac, unsuited for such a stress… :open_mouth:
Anyway in general I’ve never had any stability issue on mac with Blender, since 2.77…

Ha, ha, ha…I also had weird things like this. I sometimes can’t rename files. Simply won’t allow me to. But then suddenly it works again. Like most issues I have, they seem rather random. Also the crashes. So it’s very difficult to reproduce or even file a bug report.

That’s exactly how it was for me…suuuuuper stable…til 2.83. I think it was the most stable software I was using. It put all the Adobe apps to shame. That’s why I was a bit confused that I suddenly get these crashes in 2.83. Oh well…

I see from specs your mac should have a radeon card…
As far as I can think, that’s the only hw difference from ours (and yours previous) hw configurations… as someone pointed, sdd failure is possible, but rare… and it doesn’t seem a Blender problem…
Blender is optmized for (nvidia) cuda, not (amd) opencl… and opencl itself is abandonware… by Apple in primis…

2.83 is perfectly stable for me on Mojave. I have a 2.9 alpha (not the latest i dont think) that tends to crash.

I actually had to sign up for this site just to reply to this as I’ve been desperately seeking a solution to this. I was on 2.83 and downloaded the 2.9 Beta and ever since I’ve been struggling with a very basic room scene that appears to be corrupted. I was lucky enough to append a lot of it into a new file only to have it corrupt again. I’ve noticed the same steps to recreate is typically that I’ll click “Render Image” in Cycles and an initial crash will immediately occur. Once that happens, it fails to load the file from that point forward. This has happened to me several times now (on Mac OS) and it’s making Blender unusable.

Generally speaking, both 2.83 and 2.9 have been crashing far more frequently on Mac than any previous version of Blender. I have a fairly maxed out Macbook from 2018 that was working just fine in previous versions. It’s really night and day on how bad these latest versions have been.

Catalina 10.15.6
2.83.1 (Octane X) - Blender is stable, however OctaneServer sometimes stops working in PR1 version (no RT preview but this is not related to Blender)
2.83.3 - stable for me.
2.90.0 Beta - sometimes crashing when opening a Blender doc, so there are some problems with .blend files management indeed.

That’s very interesting - and very similar to what happened to me.
I had a file on 2.9 that kept crashing, whenever I loaded it.
When I appended collections of it into a new file on 2.83 it kept crashing, whenever I tried to append a certain collection. No way to get this collection back to work.
In a different project 2.9 kept crashing whenever I touched a specific collection. As soon as I wanted to activate or deactivate it…booom…crash.
After that, I did not dare to touch 2.9 anymore.

2.83 does not corrupt files (so far, as I’m aware of. But I’m not 100% sure), but it keeps crashing a lot. Especially with smoke sims. Sometimes also while rendering particles. And sometimes…just for fun.
It’s a real shame, since Blender was extremely stable up to 2.82 for me.
But now, it’s not great fun using it, to be honest.

Unfortunately I’m busy with some different work right now. So I can not look more into these issues or do some tests. That’s why I tried to collect some infos of other users here in this thread. To see if these issues are common or not.

Great to hear you’re using OctaneX.
I’m also planning to use it (finally get the GPU to work!), but I thought I’d wait for the free (for 1 year) version in fall.

Is there a reason you’re not using OctaneX with 2.83?
Is it not ready for it?

2.90 - The files which crash, when you’re opening them - do those files always crash or can you open them sometimes and sometimes not?