Blender 2.9 won't start ... Linux Mint Tara

I downloaded Blender 2.9 today ( .tar version for Linux 64bit) and after extracting it and trying to run it, it would start but then suddenly close down and refuse to open afterwards. I deleted all the files and replaced them back with my 2.83.5 version files and it worked again.

I’m just wondering if the minimum requirements for 2.9 have changed between 2.83 and 2.9 which may be why things are not opening up. I have a HP 250 G6 Notebook PC with Linux Mint Tara running and that seemed not to be an issue with 2.83. OK, so it wasn’t fast with heavy geometry of high level textures but for basic stuff it was fine.

Anyone know it this issue is with me or maybe others have had this problem, too?


What is the GPU of that notebook?

It’s just the standard built it GPU that comes with the laptop, Here are the settings:

Card: Intel Device 5a85 bus-ID: 00:02.0
OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
version: 4.5 Mesa 18.0.5 Direct Render: Yes

Like I said, absolutely no issue with v2.83.5, though.

If there was an issue with any of my systems settings then shouldn’t Blender 2.9 warn me that my system is not good enough instead of just automatically shutting down? This would make more sense to have an option like this.


There are some cards that are right on the edge of what Blender supports, and some subtle changes in code can make crash Blender between versions.
But it is not the case of your GPU, it correctly meets the supported specifications. You should report the problem. From Blender Help Menu > Report a Bug. You share the crash log with developers:

Thank you very much. Is there an online way in which I can test if my system is compatible with certain version of Blender?
It might save me some time in the future instead of having to ask on the forums.

Once again, thank you for your help.


2.9x has not had any change in terms of requirements compared to 2.8x.

  • OpenGL 3.3
  • Less than 10 year old

Your GPU meets those requirements.
You report the problem without fear of what the developers may say. They will confirm what the problem may be (Blender, Mesa drivers, etc).

I hate to bump this topic but I managed to get some new information.

I tried opening Blender 2.9.01 normally in Linux (Mint Tara) and, obviously, it would not open. So, I decided to open it via the terminal as suggested somewhere online. Below is the error message that I got in the terminal when it failed to open.

Any ideas if it is my system that is the problem or whether it is the program itself?



found bundled python: /home/paul/blender29/2.90/python
GPUShader: linking error:
error: Input block `ShaderStageInterface’ is not an output of the previous stage

GPUShader: linking error:
error: Input block `ShaderStageInterface’ is not an output of the previous stage

Writing: /tmp/blender.crash.txt
Segmentation fault (core dumped)

This is what was written in the ‘/tmp/blender.crash.txt’ file

Blender 2.90.1, Commit date: 2020-09-23 06:43, Hash 3e85bb34d0d7


blender29/blender(BLI_system_backtrace+0x20) [0x81fdd40]
blender29/blender() [0xe2329d]
/lib/x86_64-linux-gnu/ [0x7f52e5a69f20]
blender29/blender(GPU_shader_get_builtin_block+0) [0x6f1b270]
blender29/blender() [0x1235fe6]
blender29/blender(DRW_shgroup_create+0x1d) [0x1237cad]
blender29/blender(OVERLAY_outline_cache_init+0xce) [0x126d55e]
blender29/blender() [0x12643cd]
blender29/blender() [0x1232036]
blender29/blender(DRW_draw_render_loop_ex+0x45b) [0x123384b]
blender29/blender(view3d_main_region_draw+0x8f) [0x18935cf]
blender29/blender(ED_region_do_draw+0x811) [0x1487631]
blender29/blender(wm_draw_update+0x4da) [0x10deb5a]
blender29/blender(WM_main+0x30) [0x10dcab0]
blender29/blender(main+0x317) [0xd5ec67]
/lib/x86_64-linux-gnu/ [0x7f52e5a4cb97]
blender29/blender() [0xe1fa83]

Python backtrace

with me the same. running the regular blender file crushes. The direct solution would be to run it with blender-softwaregl. That works, but is slow. I think it’s the “on the edge” issue, I have a laptop with i5 & Nvidia GeForce 820m in it. System - Linux Mint 64.

solved. Problem was the graphic card driver. I was using on that system the open-source video-nouveau driver. When I switched to the proprietary nvidia-340 driver, blender started smoothly. So, dear MixMash, hopefully it will help you. +:)

Thank you so much for this information. I had a feeling it had something to do with this but I am surprised that it didn’t give me some sort of warning first rather than just not run.
I have had a few addons for 2.83 give me errors and not work and I have a feeling that this might be connected somehow, too.

I will see what I can do to to upgrade my drivers. Sadly, because I use a cheap laptop, I can’t replace the graphics card and I still have to work out as to how to upgrade the driver because I don’t think there is one for the one I have for my current card or that I already have the latest one.

Once again, thank you for your help.


1 Like

Just updated mesa via PPA and the error was gone:

  1. Open terminal either via Ctrl+Alt+T or by searching for ‘Terminal’ from software launcher. When it opens, run command:

    sudo add-apt-repository ppa:ubuntu-x-swat/updates

Type your password (no asterisks while typing due to security reason) when it prompts and hit Enter to continue.

  1. After adding the PPA, do system update via command:

    sudo apt-get dist-upgrade

Link with instructions found here:

Try libgl ARGS (Native mesa stack Opengl )to see if it can temporaly solve your driver problem.
You also have Mesa config already stated in your info should be no problem.

In command that runs blender put before blender args : LIBGL_ALWAYS_SOFTWARE=1 blender


Thanks to everyone who tried to help me solve the problem. Whether your advice worked or didn’t, I appreciate the consideration nonetheless.

I didn’t want to upgrade my Linux OS but I did try to update the kernel. That didn’t exactly work because of some of the errors that popped up that were too technical for me so it got frustrating to fix those errors. Eventually, I went to the update manager and realised how outdated everything was.

So, after updating everything, Blender 2.9 finally works on my crappy little laptop!

It’s incredible at how simple the solution was and how much I made this seem such a problem.

The funny thing is that someone one with a much better system than me had the same problem so I figured out it couldn’t be my graphics card or anything since it did fit the minimum specs for running 2.9

Once again, thanks to all who contributed!