Blender 2.92 lagging (a lot)

Hello,

I have been using Blender 2.92 for a few months, using the grease pencil, and it started lagging a lot on a specific file (weight: 0.92Gb), and particularly on specific scenes. So much that I can’t sculpt / undo / select / switch modes etc. without waiting at least 30 seconds… So I really can’t continue my project at all :frowning:

I have tried to open my file in a computer that has lots of RAM, but the pb remains.
I have tried to un-select “global undo” in my settings - it seems to lag a bit less, but it really does not work properly.

I saw on youtube that in earlier versions of Blender we could modify the “window draw method”, but I can’t figure out where to find it in my preferences (and don’t know if this solution would work).

Do you know what I could do? You would be my saviour(s)!!

Thanks in advance.

I guess there might be one or more objects with a high subsurface modifier cause this. Turn the value down for viewport if so.

Thanks a lot for your answer @rigoletto! Where can I find what you mentioned?
(Also, I forgot to mention in my post I was using Grease Pencil - I don’t know if it is relevant or not for my pb)

You find them in modifier tab, but if you dont know them yet, i guess you have not used them and they are not the origin of your problem. But you can find it in the modifier tab, the little wrench.

Maybe someone with more experience in grease pencil can help you.

Oh yes indeed, I know what they are, but no subsurface modifier unfortunately…
But thank you very much!

Hi, 0.92GB is a big file. I guess you are going over 1m verts. Blender has lagging problems with high vertex counts even on good PC specks (there are threads about this) and many people campaigning for improvement.

The latest posts give a bit of hope!
The work around for a lot of people was to split very dense objects into different objects.
What vert count do you have?

Hi @DNorman thanks for you answer. I don’t think I have any vertices since im working with grease pencil (maybe i didn’t understand what vertices were?) Here are my “statistics”Screenshot 2021-05-04 at 19.09.52

Hi, I think points could be equivalent to vertices but not sure never used grease pencil.

Yes I am pretty sure Points are grease pencils vertices. A vertex is basically a 3 dimensional point in space similar to what point are. You are nearly at 7 million, which are effectively 7 million 3 dimensional points in space to calculate plus the other data associated.
I do not use grease pencil but I am sure you could reduce the resolution somehow of objects (lines) that do not really need that much.
Try and save as a different file just in case. I would say you are reaching Blenders limit.
Edit:
I just did a quick test with grease pencil. If you add a monkey there are 1,216 points.

I then added another one and went into edit mode, selected all and then chose select-alternated, (it selects every other pencil point.) then I hit X and chose dissolve, this got rid of half the points leaving 629.

Then I added a subdivision modifier with one subdivision and the monkey looked practically the same the same resolution as the original. It is difficult to tell the difference.

You can disable the subdivision modifier for viewport with the icons at the top of the modifier and only leave active for render. That way you could probably half your point count and blender should be much more responsive as it will only subdivide for render not when you are drawing/editing.

Hope this helps (keep a copy of the original in-case you want to revert).

Thank you so much @DNorman !! You are right - my file stopped lagging when I tried to delete my fills layer (one of them has around 6 millions points…).
Unfortunately, it seems that I cannot do the dissolve manip you did with filling layers (it just seem to delete my filling layers).
I find that quite weird that the fills layers are using that much vertices… Do you have any idea what I could do? (you already helped me a lot ahaha sorry i’m asking for more)

Hi I am glad that you have found the “culprit” now it should be easier to fix.

I am guessing a bit because I have not explored grease pencil and do not really know about fill layers etc,

Fill layers are defined by a loop of surrounding points.

In the manual it says:
“Precision: Multiplier for fill boundary accuracy. Higher values are more accurate but slower.”

This precision or resolution seems similar to the concept of curve resolution or in modelling subdivisions and if you set it too high you will defiantly get into problems. The higher the precision the more points it would create. I suspect that when you created the fill you gave it loads of precision without realising that it would have a negative effect.

The fill layer has its own set of points so you could isolate the fill layer with the button in the objects layers tab and reduce its vert count (try select- alternated, then dissolve) without affecting the lines. If you have extremely dense points you may get away with doing this more than once.

There might be a better way to do it, and precision it might not be exactly what I am thinking, there could be a precision factor that you can lower after creating the layer (I have no idea).

If you still have problems I would start a new thread and put Grease Pencil in the title that way you will attract the attention of people who use Grease Pencil.
Something like
“HELP! Grease Pencil fill layer has 7 million points!”

Edit: I did not take in this bit:

I had a look, if you are in curve editing (strokes are like curves) you can reduce the precision/resolution with this:


If you uncheck curve editing you can access and dissolve points but the curve editing parameter is a more correct non destructive (you can always turn it up again if you want) and easy way to do it. It will automatically reduce your points count

@DNorman thank you so much for all of the efforts you undertook!!! I don’t know what I’m doing wrong, but the curve editing manip does not work as well (i does not reduce the number of points…)
I am going to try to create another post with your title suggestion.
Thank you so much for your help - you helped narrow down my pb a lot!!

You are welcome I am learning from this as well. When I did it with the curve editing “curve resolution” the stats did not update immediately , I had to deselect and select the curves again for the point count to reduce.
Good luck :slight_smile:

That’s weird, it doesn’t do it on my scene :frowning:
Thanks! I will keep you informed if I find the solution :slight_smile: