Blender 2.92 problem with particle istance - fur don't touch the mesh

I’ve a particle system with an object that render along the path of the hair, but acuatlly the object don’t touch the surface of the emitter, but is kinda detached if you look closer

here the video:

I have the same problem here. The hairs seem floating. I wish it can glow from the mesh. I tried google the answer for 3 hours. I tried “B-spline” and velocity nomal…it’s not work. I am using particle for creating some grass. Hope someone can help. thanks

  • make sure that the Mesh of your hair instance is is exactly there the origin of you hair instance is:

    (so just within the hair instance)
  • in the particle system check "Emission > source > modifier stack.
1 Like

the Mesh of my hair instance have the same origin of my hair instance
and the “modifier stack” is checked as you can see (i made a video for you):

@MaxTux Can u show us how the particle that you used for 1 hair strand?
select the object that you use as the hair instancer and go to edit mode. then show a screen shot of it?

the origin is perfectly at the center of the mesh
and even if i move the mesh along the y axe (in edit mode) nothing changes

@MaxTux it should work…

As for @gin1211 I have come across this. Yet to find an answer… Might report a bug if its not already reported. Maybe someone here knows the answer…

1 Like

those shapes are not created along the path, the problem i showed only appears when the shape is created along the path, yes i will report it

I see you already combed the hair. Have you changed any strange particly system before combing?

  • children do not respect the original positions. (those children of today, ts ts ts)
  • perhaps some rotation/velocity? or “Emitter” (instead of “Hair”) setting.

A great way for you to debug it, would be to start with a fresh, uncombed particle system (you can create it on a separate object if you want to keep the old) and see if you can reporduce it. and observe then it happens again.

I just discovered that checking “Render > Timing > Absoltue Path time” causes a similar gap:
It is only availabe if “render as Path” is selected, but applies for render as object as well (I assume because of partical instance)

You might have to recreate the partical system (or at least delete your combing) in order to apply

btw: “Render as Path” is probably recommend for your particle-instance-setup …

1 Like

solution →
1-render as path
2 uncheck b-spline

but once you unchecked b-spline you have to go back to render as object or it shows artifacts on cycles rendering