Blender 2.93 - nothing works

So I have downloaded a couple of recent nightly builds for 2.93. On opening, I can’t select any objects, either in the viewport or in the outliner (either right or left clicking). The menus work but if, for example, I open addons list, I can’t scroll up or down - either with mouse or keyboard. Keyboard controls don’t work at all - e.g. neither N or T bring up the panels. It is all very odd. When clicking on either material or rendered view, the icons are selected but nothing happens.

I have the most recent ‘official’ 2.92 version installed, which works as expected. Installed most recent nvidia drivers (though can’t see why that would make any difference).

Any suggestions? Many thanks in advance.

My set up is:
Windows 10
32 mb Ram
GTX 1060 3GB

But I’ve never had this kind of trouble before.

OK - so in the unlikely event this happens to anybody else, I solved it by loading the factory defaults, which seemingly removed whatever conflict was causing the problem. Unfortunately, it also removed all my addons which is a pain… but at least it works now :slight_smile:

EDIT: Didn’t fix it permanently. Closed file, opened with new start settings and the same thing happened (although loading factory solved it again - but clearly that isn’t a sustainable solution). Oh well. Back to the drawing board.

EDIT #2: There were some pesky add-ons with missing scripts - unticked these and now everything seems to work. :crossed_fingers:

  1. 2.93 is in bcon1, so things breaking or malfunctioning is par for the course.
  2. “Some pesky add-ons with missing scripts” is hardly a PSA. Could you at least tell us which add-ons those were and how did they come to, uh, “miss” scripts?

I do beg your pardon. Ref to PSA was a slightly tongue in cheek comment. I have deleted this so not as to offend any other sensibilities.
As nobody replied I assume this is an issue limited to my own machine. I only wondered whether anybody had had a similar problem and could advise somebody not particularly proficient with the inner workings of the software if they might point me in the right direction (it wasn’t a criticism of 2.93 and neither did I suggest I thought something in alpha should be working perfectly).
The ‘missing’ add-ons were graswald and botaniq amongst others that I didn’t feel the need to note. I have no idea why the scripts were missing. If I were proficient in understanding these things I wouldn’t have asked for help. I won’t trouble anybody again.

What I meant was that it might be premature to look for tech support on 2.93, seeing as things working today might still cause problems tomorrow.

OTOH, if you did list the specific add-ons that were the culprits in your case:

  • It could help others that encounter the same symptoms
  • If the add-ons are those that come with Blender, it could be reported on the bug tracker so that if there is some underlying issue with them the developers would have a reason to look for it and hopefully resolve it

For other third-party add-ons, I think the only reasonable course of action is to wait for their respective authors to update them to adapt to any changes a new Blender version might bring.