Blender 3.3 - GPU out of memory


I am now trying for the first time joining a challenge in Kitbash (Mission 2 Minerva) using their assets mostly. Just using less than a third of their assets already I encounter “GPU out of memory” in Blender 3.3 cycle rendering.

Can anyone advise what are the steps I should take to avoid this “GPU out of memory” issue assuming I like to continue to use more of their assets to established a scene?

I am aware that using their 2K instead of 4K textures help somewhat initially but what other steps should I consider … like should I always do “mesh cleaning” of their assets to reduces count etc?

At the moment I survive with this simple scene with statistics shown on existing “objects, vertices, edges, faces and tirangles” in the 2 to 4K range. If I add more assets from this point onwards I will encounter GPU memory issue.

Try collection instancing. That’s the default mode for very large scenes created in Clarisse and Katana. An asset will be loaded in memory just once.

1 Like

Thanks … I suppose I have to do a lot more of that. The poly stats seems to drop a lot !! and I tried add a couple more assets and it works fine so far. Cheers.

1 Like

Could render with CPU instead, will be much slower but you probably have more RAM than VRAM.

my graphic card has 8GB and PC has 32GB.
Let’s say I don’t care how long it takes to process … can Blender allow unlimited objects to be rendered ? Can we setup virtual ram on disk? if I really want a very large scene with many objects ??? any advise is appreciated.

Not sure but should automatically resort to paging once you run out of RAM.

What’s going on with the textures? Usually if I run out of VRAM it’s because assets are doing silly things with textures.

The polycount basically doesn’t matter (within reason). For example, I can easily render a scene with 20 million polygons if there are only a couple of simple textures. If you try a lighter polygon scene but with 800 textures, then it’s a problem.

I’d have a look at the assets and see if any textures can be used more efficiently (e.g. low detail/distant areas could just have a simple principled node to convey colour and some basic shading, rather than separate textures for normals, diffuse, roughness, etc.). Also, unless you really need it, you can save a lot by turning off displacement (I always forget this when using the poliigon importer, which automatically sets your render to experimental and suddenly a smaller scene is using 20GB of VRAM to render bumps on a flowerpot 60ft from the camera).

If you have also previewed many assets but only use some of them, it’s worth cleaning the unused textures (file>cleanup>unused data blocks). In some cases I’ve went from being unable to render a scene to being able to do it just because there were like 200 textures I’d forgotten to remove.

1 Like

Not exactly sure how it works under the hood, but Blender should start using your system RAM if you run out of VRAM. Will be slower though, but still faster than rendering on CPU.

1 Like

Hi Grant,
Thanks for the tips on “experimental” auto set … that I didn’t notice as I did set it to “Supported” before. Also I did do the “purge” thingy to clean up unused blocks. Hmm still have this “GPU out of memory”

Also I will try to go to each material to remove “displacement” which is not so important is large scene … lots if them in my scene, don’t know how many there are … how to check how many materials in my environment? do you know?

One other things … I notice my material has many repeats … I guess it happens when I imported each object separately (using asset browser setup).
Is this important or will the GPU treat each material (even though same setup etc) as 1 material thus taking unnecessary space. Is there a way to reduce all this .00x material and consolidate to 1 easily?

And finally continue to face this GPU out of memory problem limiting my scene setup which I think isn’t really that many assets but lots of materials (repeated) for some reasons.

Hmm appears the “duplicated material” is the caused of my problems !! … need to remap each of this duplicates. Wonder if there’s any quick way to do this … with a tool or some free addon.

Shift Q brings up a material menu with option to bulk combine duplicate materials

1 Like

Thanks … I am using this approach for now. Quite tedious as when I bring in another kitbash objects, the same set of materials get duplicated again, and need to repeat this steps for each duplicated material. Wonder if Blender have better ways to manage this more quickly.

Shift Q material combine is just what I need. I activated the add on and shift q brings up a menu of promising options but which one is duplicate combiner? That is not clear on the Q menu.

Sharing my final submission via facebook …

or u can view via my youtube channel with summarized tips.