Blender 3 - cant change the active camera when rendering video

I’ve been using Blender for well over a year now and the usual way of changing cameras in a render simply does not work for me using v3.0. I have multiple cameras in a scene, I have created markers and bound the different cameras to those markers as usual. If I scrub the timeline I see the viewport changes cameras correctly.

However, when I press CTRL+F12 to render MP4 output, only the first camera is used for the entire render. Has something changed in 3.0? I’ve read through the 3.0 docs on Blender.org but to no avail. Has anyone else had this issue with v3?

  • Jeff

Is it different when you render out sequence of images? If so I’d report it as a bug. I don’t think many will render out a video format file, but assemble the stills later.

Thanks @CarlG. It also happens when I render out as a sequence of PNG. I’ll report it and see how that goes.

Just did it in 3.1.0 Alpha and it works fine.

Tried it in 3.0 and it works fine.

I wonder if my .blend file is corrupt. When I try it from a new model with the default cube and 2 cameras it also works fine. I’m slowly recreating my model from scratch now. If I can recreate it with no troubles, then I’ll chalk it up to a corrupt blend file.

Thanks all!

Instead of recreating have you tried appending everything to a new file?

I assume you have tried deleting the markers and/or cameras and creating new ones?

I’ve never had an issue with it for images. That’s how I render out stills from multiple camera angles. Does it happen if you strip away everything but the cameras? If so, might be interesting to see how this plays out and how I’d approach it myself. Probably append as others have suggested. I have in very rare occasions have cameras that “goes wrong”, but I can never remember how to fix it so I just append them to a new file and they work again.

If it’s a bug it could be related to loading the old file in 3.0. Some things you might try:

A) Load the problematic file and then do File->Defaults->Load Factory Settings which should get rid of all settings and add-ons temporarily and see if that has an effect.

B) Restart Blender and try Opening the file and in the file open dialog click the gear in the upper-right corner and un-check [X]Load UI and see if that has any effect.

1 Like

I think the file was corrupt. I started with a new v3 blender file when the problem occurred. However, when I created a second new v3 blender file, the cameras changed correctly. Not sure how the first one got corrupted, but the fix was easy enough.

1 Like

Yes I did delete the cameras and markers. Like I said in the OP, the camera switching worked fin in the viewport, it was only a problem with the render. I don’t know what I did to corrupt the file, but I created a new one from scratch (easy to do, I had 1 .blend file to append and one FBX to import). I recreated the cameras and it all worked fine. I’m just glad it all works. Things are so much faster in Blender as opposed to iClone for rendering and physics.

1 Like