Blender 64 - Performance error, settings perhaps?

Hey all.

I decided to try out the 64-bit version of Blender, yes I have an OS and a CPU that are 64-bit.

The problem is this: There was a project I worked on awhile back that, in 32-bit blender had started causing me performance problems so I dropped the project in hopes that perhaps later I could return to it.

I loaded up that project, and even so the performance problem is still there even on the 64-bit (which I believe is supposed to be able to access more memory, I have eight gigs of ram but I don’t think Blender is even coming close to tapping that)

Do I have a setting not set or what?

Are you referring to real-time performance, in the 3D view? If so, I doubt that a 32-to-64 bit upgrade will help much, if at all. That will allow you to access more memory, and load/render larger scenes … but as for working with all that data, displaying and updating it in the 3D view as you make changes, that’s dependent on your graphics card.

I have a GeForce GTX 260, 896 Ram. So I dunno what is causing this issue, it shouldn’t be considering how advanced that card is.

Yeah, with that card you shouldn’t have any serious issues. What exactly are the problems you’re seeing? What are the specs of your system, and the file you’re working on?

The file I’m working on is for a space-based carrier, it’s got quite a few turrets on it (which I know contributes to the performance) which all I did was make one turret and then copied it several times across the board.

After awhile, as I tack on more details to the ship, Blender starts to get choppy. Meaning it no longer becomes a smooth camera movement and instead the screen skips along - the more ‘details’ that are added, the worse it becomes. For example; if I enable the layer that has all the turrets (there are at least forty of these turrets, twenty on top and on the bottom, give or take) Blender’s performance takes a sudden step dive where it’ll take several seconds for me to even more the camera unless I disable the layer in question.

I run on a Intel Core 2 Quad Q9300 with 8 GB of ram on a Vista 64-bit OS (Ultimate)

My sig has the specs of my machine, and it’s not very different from yours. I just did a quick test on a scene of mine: all layers visible with over 1 million faces, GLSL shading enabled with 16 lamps, two 3D views filling the screen … then I duplicated everything. The duplication caused a momentary pause, but after that view navigation was still pretty responsive.

I have noticed while actually working on this project that Blender does occasionally ‘lock up’ for about 10 seconds, but I think it may be a bug/stability issue with the 64-bit build … even this official “64bit release of Blender for Windows is still in a development stage”, as stated on the download page.

How many faces are being displayed in your scene when the lag becomes evident?

Well, the performance issue is also in the 32-bit version, though I did notice that the issue was more noticable in the 64-bit when I brought up the file.

With just the base layer (which has the ship) and the turret layer active:

Faces: 1,651,157
Verts(I’m assuming VE means verts): 1,618,062

I also have not edited any of blenders default settings; as I don’t know if doing so would help.