Blender & 64bit Jaunty?

Anyone had any luck with this combination? I’ve tried apt-get, running it from the desktop via clicking the blender icon, desktop via a terminal command, & installing via GDebi…all of this with both the standard Linux 64 bit & Ubuntu 9.04 packages. The scribble in the screen-shot is all I can get when trying to select via mouse, plus it’s incredibly slow. This is the only thing I’ve gotten no matter what the install method or package. Compiz visual effects are disabled.

Edit: I get this console error but I don’t know what it means:

File r300_render.c function r300Fallback line 374
Software fallback:ctx->RenderMode != GL_RENDER

I’m using open-source gl drivers from the standard install since they seem to work so well with everything else (gl-extra screen-savers, Compiz, etc…). ATI restricted just doesn’t seem to work at all for this distribution.

Jaunty comes with blender installed. I think 2.49. You have to get the upgrade 2.49a for ge video to work though.
I run it right out of the box from my desktop. I open a terminal type: Desktop/blender2.49aStart/blender.
I hope my noobish reply helps some.

Good luck,

You need python 2.6 which jaunty also comes with.

I don’t know how to fix it, but I think you should be looking more at the graphics drivers. ATI and linux is not always a good combination. Also if you have very new hardware the support for it may not be there yet.

I hope you find a solution though. Did you try posting at ?

EDIT -This might be useful

Thanx for the replies guys. That link looks like it just might be the ticket.

One of the solutions is to run Blender without hardware acceleration using this command:


For some reason Organic’s method doesn’t work with 64 bit Jaunty (it reverts to low graphics mode and I have to revert to the default xorg.conf file) but The Verb’s method does work. I found that I get this error message when trying to add the string to a custom pannel icon and Blender won’t start up.

(as an application in terminal):

“There was an error creating the child process for this terminal”

But when I added sudo to the front of the string the icon launcher does work (I just have to enter a password but that’s a small price to pay for easy access to a Blender that now works correctly):


Thanx for the help guys,

I had pretty much the same problem in Jaunty-32 with an integrated intel graphics card. But I don’t have that problem anymore with my new laptop (a nvidia hybrid setup). So I’m pretty sure its a graphics card/driver problem. I was never able to solve it on my old laptop. :frowning: