Blender Add-on Manager v1.1


(Nutti) #1

Hi,

There is lots of attempt to manage add-on (install/uninstall/update) so far.
However, there is no solution about this issue.

So, I developed application to manage add-on released on GitHub.
You can install add-ons released on GitHub (more than 2,000 add-ons are released)
Also you can update/uninstall add-ons installed on your PC.

Add-on information is stored on my Add-on database which is updated everytime, so you can update add-on without searching GitHub repository.



This project is on going.
I think there is lots of bugs about this application, and I will fix as soon as possible if bug is reported.

[Download Page]

[Features]

  • Search add-ons released on GitHub (more than 2,000 add-ons are avaliable)

  • Manage add-ons
    [LIST]

  • Install add-on released on GitHub

  • Uninstall add-on which is already installed (only External support level)

  • Update add-on released on GitHub

  • Favorite [New!!]

  • Migrate add-ons among different Blender version [New!!]
    [/LIST]

[Support OS]

  • Windows (32bit/64bit)
  • Linux (64bit)
  • macOS (64bit)

MacOS will be supported in next version. please wait …

[Tutorial]

[The Project Page]

Hope you like this application.
And, please report bug you find and feedback.


#2

Who!!

Really usefull, but will be well have a link to the addon (a lot of addons don’t have description) and a scroll bar.


(AlexMcKonst) #3

It really inspires


(Arcan) #4

Excellent! I discovered so many add-ons I never even knew existed and…can keep them updated!
Thank you for sharing!!


(urkokul) #5

Thank you very much. Super.
And, please, add possibility to select a custom folder for addons


(Manolo76) #6

Hi,

I tried your add-on and it works at the beginning (Blender 2.78c x64 and Windows 10 x64, I updated few add-ons) but now, I have an almost empty windows (see screenshot).

I updated Sniper add-on from your add-on and next, I checked in Blender if it was ok but the Sniper add-on had “missing files”. So I downloaded the last version of Sniper Add-on (1.3.2) and installed it FROM Blender and Add-on Manager doesn’t work anymore. I’m not sure if it is the reason but I let you what I have done.



(Nutti) #7

@AlexMcKonst
@Arcan

Thanks!!

@DCVertice

Thanks for your feedback.
I already add your request, and will be available in next release(v0.2).


@urkokul

Thanks for request.
I’m in implemented this feature now.
will be available in next release(v0.2).

@Manolo76

Thanks for bug report.
I’m investigating the cause now. will be fixed in next release(v0.2).


(AlexMcKonst) #8

And I have such a problem


(fiendish55) #9

how about addons that you have paid for? Current problem with cgcookie auto addon updater is this same thing we need solution that brings all addons in same manager paid or not.


(Nutti) #10

@Manolo76
@AlexMcKonst

Sorry for inconvenience.
I fixed this problem now, and will be in next release.

@fiendish55

Thanks for your indication.
Non-free add-on will be excluded because this add-on manager focused on GitHub add-ons.
I will add feature to exclude non-free add-on from this tool.

I think cg-cookie’s updater needs developer to do some extra work.
This tool does not need it because I setup own add-on database on my server and fetch add-on information from there.


(jpthrash) #11

Thanks for the tool. It actually exposes a lot of obscure addons. Very helpful.


(draguu) #12

Hello,

I wanna try but i m stuck at installation … and there is no documentation for how to install it ,
i am using ubuntu 16.x

i open blender addon manager file, and it shows me one dialog box , and it gives files to protect menu and gives only two option go and quit

i pressed go and it gets me to another window asking for where to save par2 files , i added path to an empty folder and press next ,

it does some processes and then only option left is close and quit

how do i get this program running ???


(system) #13

It’s a dream to have an addon like this, but so far it didn’t work out for me; after updating for example the addon tissue, blender showed “fake module–addon missing,'bl-info’give bad performance”. Removed that from the appdata… folder > Installed the addon tissue from official website, and Tissue is running again. I tried 5 addons, and with one addon I had luck. Any suggestions welcome, maybe I am doing something wrong.


(Nutti) #14

Released v0.2


This release has below new features.

  1. Support macOS (ia32, armv7 version is removed)
  2. Link button to Add-on repository (request from @DcVertice)
  3. Case-insensitive search

And fix bug @Manolo76 @AlexMcKonst @robwesseling reported.

@urkokul @fiendish55

Sorry, your request makes big change to current source code.
I will add your request in next release (v0.3)


(ParanoidFactoid) #15

Running Yosemite with Blender 2.78c. Downloaded Blender_Add-on_Manager-darwin-x64.zip from github. Tried install from file. Log reports that it copied the file into the addons directory. But it doesn’t appear to be in the addon list to enable it.

Ah. It’s an application. I’m being very dumb. Yeah, it starts.


(ParanoidFactoid) #16

Installed on Yosemite w/ blender-2.78c. It updated the .db file, which is now 2.2MB in the correct path down /Applications/Blender\ Add-on […]/db/add-on_Manager. No obvious errors in app.log or lib.log. But I get no add-on list in the app browser. Nor can I search. It’s entirely empty.


(Guziczek101) #17

Hi Nutti i have small problem with your addon i just opened it and i dont have blender ver and the right window is empty (no connection to server? )



Windows 10 Home Edition


(GCRev) #18

This is one of the most useful things. Many thanks kind sir!
A minor suggestion: you might consider sub-sorting options such as “alphabetical” and “recent.”


(Nutti) #19

@ParanoidFactoid

Thanks for your report.

If you are possible, can you upload application’s screen.

@Guziczek101

Thanks.
I have two questions about your issues.

  1. Have you installed Blender?
  2. Have you installed add-on after installing Blender?

@GCRev

Thanks for your request.
I think it’s good improvement. i will add your request on or after next release.


(fiendish55) #20

Or maybe just common search tab if you already know what specific addon you are about to install :slight_smile:

Ok blind me there was one already. Only thing keeping me actually installing this is the feature include paid addons like hard ops and such =P