blender and sl sculpties

Hi…

I am wondering where I might ask for help with importing wavefront obj files into blender and exporting those as second life tga sculptie maps. I do am a bit clueless about any of this 3d stuff

What I have (and this is what I got working) is Blender 2.48a, python 2.62 and a suite of python scripts that allow me to create and export sl sculptie maps. it is called …well I cant see what its called, could be primstar but its by Domino Marama.

Create, Import & Export Sculpties In Blender by Domino Marama
Copyright 2007-2008 Domino Designs Limited

Next I followed this tutorial and it all worked…I made a ball that I succesfully imported into secondlife
http://www.masterprim.com/class/how-to-use-blender-create-second-life-sculpted-prim

.
Next I tried my obj file. I imported it into blender and it all looks good, I followed the same basic steps as in the tutorial, split the screen, selected the uv/image editor stuff all that, dont know what it means yet, smiles, and hit render, it failed…with errors along the lines of

sculptimage = mesh.faces[0].image
ValueError: face has no texture value

So I guess I have three questions.

1 - Is this the place to ask and is there anybody here that does this kind of stuff
2 - what does the error mean, – my obj file seems to have texture, well it looks like it does.
3 - how then do I fix it?, well, some pointers or clues at least, smiles nicely.

I know this is not a blender problem, but I am hoping like crazy that there are some people here that might be able to help me.

Thanks and fingers crossed

Cheers

DW

Just a point. If you use blender 2.48a, this needs python 2.5.4 not 2.6. Don’t know is this is what is causing the error. You should update to the latest blender version which is 2.49b and this does use python 2.6. The tutorial you link to uses this latest version.

http://www.blender.org/download/get-blender/

Richard

Thanks Richard

OK I have updated to the lates version of Blender 2.49b and still have the same problem.

I then re-created the ball from the tutorial and exported that as an wavefront obj file. Restarted blender imported that file and rendered it as a sl sculptie …so to me it seems, at least, that obj files as such are not the issue.

Thanks

Cheers

DW