blender black screen windows 10

Hi, my laptop is lenovo z400 with spec:
intel core i3, 8gb ddr3 ram, and nvidia gt740m with windows 10 pro 64bit

so when i tried to run blender with high performance (nvidia) then it will show blender with blackscreen… but if i run it in integrated graphics then it will work fine…

but don’t you think it kinda pointless for me to have nvidia gt740m but not using it into much need graphic performance
program?

note: i already download/update latest nvidia driver and also blender program

Yup, “you really don’t have it if you can’t use it” :eyebrowlift:… ok, joke aside…

Using window drivers or nvidia’s? Rolled back to previous?
Checked settings in nvidia’s Control Panel? Tried with Performance VS Quality?
Any other Blender version tried? At default system settings, still?
Dual graphic system? Checked BIOS settings?

play around the lovely game of Trial & Error :wink:
or maybe… https://developer.blender.org/T37027

It’s probably a bug that nobody cares to even try to fix, either in Blender or your driver. Hybrid GPUs on laptops have always been a nightmare. I would strongly avoid those in the future, in favor of a stronger internal GPU. The Intel Iris Pro chips are actually pretty good.

You may want to figure out if you can disable the internal GPU in the BIOS. Also, don’t assume that using the 740M will make a huge difference for the Blender viewport.