Blender constantly crash or render cancel when i try switch to rendered view

Hi, I have been experiencing these in the last few days and I cannot do anything with my work which is very upset.
**Whenever I try to use GPU render, it automatically canceled without any error. and if I close Blender, it’s not responding, I cannot even close it in task manager, the only way I could close it is to reboot my PC.
My blender has been running well before without any adjustment in hardware and software.
I tried in Cuda, Optix both in 2.81 and 2.82 (i am downloading 2,83 and wanna try last time)
None of them work.
I could only use CPU render now which is a pain in the ass.

And I also notice in the console window, when I use Optix render, it said “OptiX implementation does not support shader raytracing yet” and then cancel.
And when I use Cuda, at first it could render, but it took way longer than before, and if I have any adjust the view in the render, blender goes not responding, and then I have to reboot.

1 Like

Hi, I have exactly the same problem. When I’m in real time cycle rendering, not when I launch a rendering (which works).
I have 2 graphics cards (rtx 2060) which worked well until 2.79, since 2.80, I have this freeze with obligation to restart the machine, sometimes even by the button !
If I desactivate one of them, it’s running. when I Have the 2 cuda selected it’s freezing !
Sorry for my english !

Hi,
my problems have gone, but I am not sure what I did finally solve it.
Try the following

  1. if you are using Optix, make sure you are not using the following features, which is not supported by Optix for now
    • Baking
    • Branched Path Tracing
    • Ambient Occlusion and Bevel shader nodes
    • Combined CPU + GPU rendering
    • Using CPU memory for bigger scenes
  2. Trying using only one GPU Render while previewing it, I have two 2070 super and always crash when i open them together, so in the preference setting, only enable one GPU to test if it will solve the problem
  3. Try decreasing the Tile size, sometimes the tile size too big can run out of GPU memory, I used to set it around 500 after set it to 256, it sometimes works.
  4. Try to remove all the third-party add-ons, some may conflict with the render.
  5. Lastly, try to reset your blender.

Let me know if it could help, mines ruing well with Two GPU right now.

Thanks !

I don’t use Optix, I use CUDA with the 2 cards selected.
THe probleme appear when the 2 are selected if I select one, I don’t have any problem. But when I want ton render a scene I must select the 2 for each render.
I don’t have the problem when I render a scene, it 's just when I controle a render before render it (Z : rendered when Render engine selected is cycle, no in evee)
I Have test in original blender, without add-ons activates, but the problem is the same.

i have no idea how my problem solved, i tried a bunch of methods. reinstall few different versions.
i think smaller tile size do help, have you tried that?

Don’t forget update your solution if you solve it, think it could help more people

1 Like

HI, did you have problems like viewport rendering very slow and sometimes crash.
Do you find that the CUDA is not fully used while all these slowing happened? like the screenshot i attached.


The cudas were not been constantly using at a high rate, which is weird.
If you have notice the same problem, please let me know.It could be helpful for solving this problem

Hi, sorry I didn’t have time for testing !
I have just change one of my Graphic card, to test if it’s changing something, but when it crash, I have to reboot the PC it’s so long, I must Have more time ! lol
But when my tests will be ok, I will remember to speak about its, here !
Ok, for you last question, I try it !

1 Like

Hello, i have the same problem. Also a dual GPU setup … with only one GPU active i have no problems … kinda frustrating …

sorry about your experience, i am still suffering from this and have no idea.
Did you have the same CUDA usage pattern in task management when using dual GPU?

@Bao_Richard

I was experiencing the same exact issue.
Reverting back the Nvidia drivers to 441.28 worked out for me.

1 Like

This is a screenshot shortly after the error occured.

Ok, i will test that. Studio or game ready driver?

Studio driver.

Thanks, gonna try it right now!

It worked for me! THANK YOU!

Glad to hear that!

I was having issues with E-Cycles but the symptoms are just too similar so most likely something is definitely off with the latest drivers. Credit for the tip goes to @bliblubli for giving me that advice.

1 Like

The first time I try everything works, then when I tried the second time, it’s back to the same.
Don’t know why. Maybe i need to try roll back even more…

Did you try DDU?
If not, here’s what I did.

First, you need this

Press WIN + R keys and type msconfig and from here do this

Once you are in safe mode open DDU and apply these settings (I found this on a Nvidia forum)

Then uninstall the GPU driver.
Before rebooting re-open msconfig and turn off the safe mode.

Finally, install the older driver and reboot.

I had followed your suggestion and it seems two GPU can work with a consistent CUDA Usage, but while rendering in viewport, if i move around, sometiomes it will make the render canceled.
But i am pretty happy two card can work together now.