Blender + cortex-vfx

Hi, all

I’ve been developing a small python module
to integrate Blender 2.5 and Cortex libraries,
and I thought it was interesting to share.

Right now, there is a minimal IECoreBlender module
and and addon with exporters for cortex objects and attribute caches ( vertex caches).
They work only for meshes (for now). I could import the resulting
files in Houdini without problems.

The code is in github. I also included a 64 bits
linux package ready to run, that also has Matt’s
3Delight addon and Disney’s partio python module.



Thanks looking into this…

Thanks heaps for building this!

Sorry for digging up this thread but I’ve got a question. Correct me if I’m wrong but do I need to build Blender from source, with dynamic linking to use IECore module?
I’m getting “No module named _IECore” error every time, even if the is placed in PATH. I’ve figured out that the blender distributed via is being staticly linked. Am I right? :> :slight_smile:

Yes, you need to build Blender with python dynamic linked. In some linux distros, python is not correctly build.
If you build your own python, pass --enable-shared to configure when building.

Cortex uses python 2.x. If you want to build a newer version, there’s a diff for python 3 support
here: Patch cortex and build as usual.

I wanted to update the build and IECoreBlender to the latest cortex, 3delight, …
versions, but I didn’t have the time yet. I’m also hitting the Graphical 50 mb limit.

Hi. Thanks for the reply.

I’ve managed to build python3.2 with --enable-shared option, then I’ve built boost-1.42 using linking to this custom built python. After that I’ve successfully built blender 2.61 with dynamicly linked python, when that happend I’ve moved to building cortex-6.0.0.
Compilation ended well but when I’ve tried to import IECore module I’ve got this error:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.2/site-packages/IECore/", line 47, in <module>
    from _IECore import *
ImportError: No module named _IECore is placed in the IECore module directory, I’ve been trying to put it in PATH and in LD_LIBRARY_PATH, none of it worked. What am I doing wrong :frowning:

I want to keep this thread alive. Some of us SoCal Blender users are looking at Cortex again for use in Los Angeles studios. I will be taking a closer look at the git repo and post here any thoughts.

Thanks, JTa

Hey Est777 your repo is down. Any way I can see the code just to take a look at how you integrated it even though the codebase it is for is old?

Thanks, JTa

Hmmm…Image Engine just make a commit June 2013 so it looks like it is still being used in house.

This download link on graphicall has some good info in addition to the Linux 2.60 build.

It looks like Cortex has a code commit July 2013 and its companion Gaffer from Image Engine has a commit recently.

Cortex was mentioned in dev chat again. Also there was a Gaffer BoF at SIGGRAPH. There is still also activity on the googol code pages. So this project is not dead it looks like. The crowd engine still seems like a fun integration to me if it can be made to work with Blender. Just thinking…