Blender crash when I switch into GLSL Materials

Hi folks

On my laptop I have: ATI Mobility Radeon X1350 + Windows Vista, when I switch into GLSL Materials program crashes. Any ideas why/what to do ?

If you have real time lighting on with a high buffer size it can cause weaker ATI cards to crash, either turn it off or select your spotlight and turn down the shadow buffer size. That is the only crash I have even had occur with ATI cards in glsl mode, so give the fix a try.

Hi gomer, I create a new project with default cube, switch to GLSL, change view to textured and it crashes.
Do you also have a mobility ati card, or a desktop one?

Well, it wasn’t me who had the issue, so I can’t tell you the exact card. Try going into the game menu, hovering your mouse over the glsl material settings, and then turning off shadows in the menu that pops up, then turn on glsl materials. You can try turning off all of the different options to find the one causing the crash, then put it in a bug report I guess.

I’d make sure that you have the newest ATI drivers. I’m definitely not a fan of ATI cards, so I can’t give you a lot of help, but you can get them at

Hi guys

Installing the newest drivers helped!
It’s quite a task but there I found a simple solution: