Blender Crash when previewing on cycles

Just buy a new motherboard asrock z97 pro4, an intel core i5 4460 @ 3.20 ghz and a 8 gb vengeance memory. Power supply 620 watt. Graphic card. gtx 560 ti 1gb
I am on win 7 64 bit

Each time i previewing a simple scene with cycles with shift-Z blender close without any warning or error .
Even with the new blender 2.76 rc 1.

I never have this kind of problem before with my last pc with the same graphic card, core 2 duo, asus p8z… .

Does it crash when using cpu, gpu or both
If gpu only maybe running out of graphics card memory (you say you only have 1GB).
Does it crash when preview rendering only or also when rendering your scene. If only preview are the render settings different between them and do you have objects in the viewport but not when rendering
Ensure you are using the latest graphics card drivers

Just when using GPU preview (Shift-Z), it crash, but not when pressing F12 on GPU. CUDA enable in preferences.

Hi, I found this error in the console.
“<!> event has invalid window”
Blender keep crashing each time i press shift z in the viewport for preview using Cycles+cuda gpu ( even rendering the default cube) but not when pressing the render button

Final render renders by default in tiles, while the preview render is a progressive refine render of the whole viewport area. Memory consumption of the latter is significantly higher and will most likely be too much for a card with so little VRAM (1 GB - I’m actually surprised that you can render the default cube at all!).

Try enabling “Progressive Refine” for the final render: I’m quite sure you will see Blender crash then, too.

Hi. All was working fine before i change my motherboard. I try another graphic card ( gtx 750 ti 2 gb ) blender still crashing just when previewing with cycles. Render with f12 render fine.

Still haven’t found a solution about blender crashing when previewing. Pls help

Could you try Blender 2.71 or 2.72 with the GTX 560 Ti?

As Richard and IkariShinji said, You should expect “out of memory” errors even with default cube in new versions of Blender:

If the GTX 560 Ti card is the one connected to the monitor, you disable Aero and all Windows 7 effects to reduce the use of vRAM.

Use CPU for viewport editing and preview if you experience frequent quits.

I also have similar problems - only on GPU viewport preview and mine also started when I changed my motherboard, and I also have a Z97 board. (I used to have a AM3+ board, used that for years with the same GPU without a problem).
I have a 4GB GPU so it’s not memory related, and I also can’t find a solution. I use Intel Graphics Processor as display, this could be a problem, but I couldn’t verify it yet (also I can’t see why it would cause a crash).
Any input on this or anyone else with a Z97 + GTX who could test?

@galingong.Is the Z97 motherboard an asrock?

@YAFU. Sorry Maybe I haven’t explain well. I never has problem with motherboard nor graphic card memory limit until i change my motherboard for an Asrock z97pro4. All was working fine before, and I decide to change my mboard for one which support core i5-i7. I should go for an asus instead of this brand. This should not about bad driver because I try to format another pc with an msi mboard without installing any driver but just nvidia for my graphic card , and blender preview work fine. Is there imcompatibility with this motherboard?

You’re right, in the case of what I said Blender should only report the error, Blender should not crash.
Do the GPU problems occur only with Blender? Have you tried any other app that makes use of GPU computing (CUDA / OpenCL)?

Maybe you could see if Luxmark also crash when performing the benchmark:

It is weird that the problem only happen with rendered view. Perhaps some of you should report the problem in:

Or return the motherboard.

Problem has been solved after installing windows 8 instead of 7 on this board.

Mine is a Gigabyte board. Appearently my problem is gone as well (fingers crossed). I plugged my display into my GTX card and disabled onboard Intel Graphics in BIOS. Rebooted, then I switched it back, plugged the display back and now it seems to be working. Theoratically I’ve did nothing, so the whole thing is weird.