Blender crashes at startup

I have been testing the python script found here:

Everything was going fine until I imported a large dxf file and tried to save it to the test blender file. At that point blender crashed and when I tried to open blender again I got the Windows dialog saying Windows was unable to open the program and would I like to send a debug report. After unsuccessfully trying to find the problem I decided to uninstall and re-install blender. Unfortunately this didn’t cure the problem either. I got the same dialog that says “Windows wasn’t able to open the program”. I would upload a screen shot but I’m sure most windows users have seen the dialog I’m talking about. I have been running Blender for 2 years on this computer with no problems at all. I do still have blender 2.41 on the same machine but it is in another directory. I don’t know if that might be a source of the problem but I’ve been running both side by side for quite some time now so I don’t really think it is.

I’m using:
Window xp pro
Pentium M 2.10GHz
Nvidia GeForce FX Go5650 Graphics Card 128MB

Any ideas or suggestions would be greatly appreciated.
Thanks in advance.

i see you un-installed, but are you sure .B.blend got wiped out? you might erase that.


I did delete the b.blend from the 2.42a directories but I am wondering if the b.blend from my 2.41 installation might be getting read somehow. When I do start my 2.41 version the b.blend file seems to be in good order.
Thanks for the thought.

I did some testing on the .b.blend file in my 2.41 version to see if perhaps it was the problem. I moved the current b.blend to a different location to have blender create a new one. I restarted blender 2.41 and blender opened with a default cube scene but I could not find the b.blend file anywhere. I did a search of the whole hard drive and found nothing but the b.blend I had moved.

My question is: Shouldn’t the b.blend be created in the directory that blender resides in?

Never mind. You must hit ctrl+u to have the b.blend file written out. And it is in the blender directory.

Edit #2:

Well to anyone who cares I found a fix to the situation. I sacrificed my 2.41 version and just loaded 2.42a on top of it. All is now well in the universe. Never really figured out what the problem was but the overwriting of 2.41 took care of it.