blender crashes every time I try to open a saved .blend file

Have anyone encountered this problem as I did?
Blender crashes every time I try to open a saved .blend file
I can’t open any saved .blend file.

My Blender version is 2.44 on LINUX Ubuntu

Can someone help me with that?


P.S.
Sorry for the poor English.
I’m not a native speaker, but I tried my best.
And thanks for your help in advance.

yea, i had the same problem. you should backup all your saved .blend files and reinstall blender

I tried the method you suggested, but it didn’t work. (removed and reinstalled by “add/remove” from LINUX Ubuntu)
Thank you iliketosayblah, anyway.
Is there any other way to solve this problem?

Well if the blend file is corrupted, you could try to Append (Shift F1) your objects one by one into a new blend file, saving after each one, to try to retrieve as much as you can from the file.

I found out that even adding a curve causes a crash. (But I can add a metaball or a cube successfully.)
Maybe it crashes whenever Blender consumes too much CPU suddenly.
Is it possible? If so, what can I do with that? Upgrade my computer hardware?

What are your system specs?

OS: LINUX Ubuntu
CPU:Pentium 41.50GHz
RAM:512MB

I’ll post more information if you need it.

Although its not optimal, Blender should run fine on your machine. Try File>Load Factory Settings and add a curve, to see if it crashes.

No luck.
File>Load Factory Settings and add a curve…
then it crashed immediately…[email protected]口@~ {why?