blender crashes immediately upon execution

Hi blender folks!

So I’m running linux mint mate on a lenovo laptop with a pendium dual core(I know…), 4 gb ram, and “screaming fast” integrated intel mobile gm965/gl960 graphics(I know…)!

I had blender 2.76.b(mint build) installed and was working with it for some time. Yesterday, I did a bunch of updates and blender worked yesterday. Today, blender started crashing upon execution. It opens a window frame that has nothing inside and closes it within a second or two.

So I downloaded blender 2.79(blender build), but that suffered the same problem of crashing immediately also.

I think there is a problem with the graphics drivers because…

Here is my blender.crash.txt

Blender 2.79 (sub 0), Commit date: 2017-09-11 10:43, Hash 5bd8ac9abfa


/home/user/Desktop/blender-2.79-linux-glibc219-x86_64/blender(BLI_system_backtrace+0x20) [0x1a6c8e0]
/home/user/Desktop/blender-2.79-linux-glibc219-x86_64/blender() [0x107a525]
/lib/x86_64-linux-gnu/ [0x7fc04625f4b0]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033eeb986]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033eed07e]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033ee4468]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033ee5345]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033d064da]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033d06ddd]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033d3d333]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033a8b12e]
/usr/lib/x86_64-linux-gnu/dri/ [0x7fc033a90da3]
/home/user/Desktop/blender-2.79-linux-glibc219-x86_64/blender() [0x107e11d]
/home/user/Desktop/blender-2.79-linux-glibc219-x86_64/blender(wm_draw_update+0x3fe) [0x107f7ae]
/home/user/Desktop/blender-2.79-linux-glibc219-x86_64/blender(WM_main+0x28) [0x107b118]
/home/user/Desktop/blender-2.79-linux-glibc219-x86_64/blender(main+0x3f8) [0x1018bd8]
/lib/x86_64-linux-gnu/ [0x7fc04624a830]
/home/user/Desktop/blender-2.79-linux-glibc219-x86_64/blender() [0x107747e]

I have to say, I don’t have any graphics intensive programs on my computer besides blender right now. For what it’s worth, free-civ still works and it’s gtk2 and I don’t seem to be experiancing other problems with video,

Anyone have any ideas on how to fix it?

I have now tried the 32bit version of blender and I get a different response. Basically it doesn’t even execute.

a message box appears and tells me:
Failed to execute file “blender” Failed to execute child process “…pathto/blender2.79…/blender” (no such file or directory.)"

What permissions do I need? it’s rw,r,r now.


Another update: some progress.

I have found some config stuff at /home/user/.config/blender…
I deleted this and uninstalled the repository version of blender.

now if I run the downloaded blender 2.76 and run with ./blender-softwaregl the program runs, but is too slow to use.
Since it won’t run without the -softwaregl switch, I think the problem is my graphics driver, which is too bad because everyone hates my graphics chipset(for good reason too) and there isn’t much support on it.

If I can ever log into the mint forums, I’ll post the issue there, but they haven’t activated my account yet… it’s been a long time now.

I will leave this open, in the hopes that someone will stumble upon it with a solution. To be frank, however, I don’t think this is a problem with blender, rather with mint or a driver provider so if the admin closes this I won’t cry.


So I think when I upgraded my kernel it killed mesa and when I upgraded mesa it fixed it!

Fixed with a mesa update. upgraded to mesa 17.2.4 for kernel 4.8.0-53.1 on mint.

Back to Blending, baby!