Blender crashes instantly on scene change

I’m using a laptop, HP, AMD GPU, running Windows 8.1 Blender 2.74. I’ve never previously had any techical difficulties (similar to this one) with Blender and I have been using it for about 2 years.

I have a .blend file that I was working on about a month ago with a rigged character from MakeHuman that has been modified and re-done to render in the internal engine and freestyle to produce an Anime-style effect.
The original model was imported using the Makehuman exchange format.
Today, I created a new model of the same character but younger, and decided to put it in the same .blend file in a new scene.
I used exactly the same settings as before, and imported the model in exactly the same way.
I was starting to modify the new model when I decided to delete the original MakeHuman hair that I had used as a ‘placeholder’ (if you will) and go into the other scene and take the hair from there that I had modified and scultped and done ‘stuff’ to (etc.).
Basically, Blender crashed instantly.
I started it up again and tried to do exactly the same thing about five times, with exactly the same result.
The only difference when I started up the other times was in a long list of error messages down the screen that looked like this:
And the whole screen (to get a sense of context):
To me, the error messages are really ominous, as it suggests that my model has been lost. Can anyone suggest a method of extracting the model (in any condition) - I would be seriously grateful, as although I still have the base mesh, I don’t have any back-ups of the modified mesh.
I’ve attempted to copy, append or otherwise import the mesh using the outliner panel and I get exactly the same result. Getting rid of the new scene also produced the same result, as did adding the scene into the VSE. I temporarily removed .blend1 files from the vicinity of the file and started it up. Exactly the same result occured, but without the error messages on startup.
I don’t know if this is a bug, or if something has happened to my .blend file, but any suggestions into how to get the mesh back, or anything that could recover my work and/or prevent this from happening in the future would be most welcome.
You can find the .blend file here: (I’ll take it down when the problem’s fixed)
Thank you in advance-