blender crashes on complex scene with raytracing

hi!
i’ve got a quite complex scene with lots of details and some (plane) water-surfaces in it, which i need to be reflecitve. so after not having success with environment-maps ( anyone remember this thread http://blenderartists.org/forum/showthread.php?t=108083 ? :wink: ) i tried to use ray-mirror for the water - and it turned out to be even faster than environment maps. but sometimes blender seems to be not capable of rendering the scene with all objects and details. if i press “render” it crashes immediately. it can’t be the RAM, it takes around 500MB, and i have 4GB (and the 3GB trick enabled). also, it happens only with “ray” enabled and mostly only with OSA 8. sometimes it works, sometimes not. then it can be that “render” works, but as soon as i press “anim” it crashes as soon as it reaches the secand frame. so, does anyone have an idea? perhaps some hidden raytracing-speed-ups or scene-linking or other tricks?
there is an image of the scene attached. i have to render an animation with 3500 frames soon, so it is quite urgent and any help would be very appreciated. :o

Attachments


try launching blender from the commandline… you might be running out of ram… have blender render your scene in the background without the GUI running.

This has helped me in the past with huge scenes.

thanks for the answer!
however, i don’t think it’s the RAM. sometimes blender does render the scene, and then it doesn’t take more than around 500MB (at least, that’s what the render-headline says - and the tastmanager as well). but if i manage to render the scene once, and want to do another render afterwards (or just do the “anim”), i can be sure that blender crashes. maybe two many faces? or two many procedural textures? i just don’t know.
and of course i tried with “save buffers” and “free textures” - no difference. sometimes it renders, sometimes it crashes. weird. but anyway, i’ll try the commandline.
i read somewhere, that it can make rendering more stable when you split your scene into different scenes and render them from a third scene, where you put them all together. maybe someone knows something about that?

okay, problem solved. it seems that blender doesn’t like too much objects for raytracing. i excluded the (?) handrails around the (?)(don’t know the words) basins from raytracing via material settings, and voilá - it works! i can render the picture above in HD, OSA 16 with shadow and raytracing AND full ambient occlusion - and no problem. so it seems that blender has a limitation for the amount of raytraced objects. hm…

Maybe some of the object that you removed had some normals inside. I have encountered the problem with Indigo recently.

ah, interesting! indeed, that could be, as the handrails are beveled curves. i have to check this.