Blender crashes on particle system render

Hi guys

I’m trying to render the linked scene (the upload manager keeps telling me the upload has failed so I’ve linked to it in my google drive instead, its only a 3MB .blend file…) and in playing around with any higher values of emission or children Blender crashes on both the CPU and GPU when I try & render.
https://drive.google.com/file/d/0B_Yewsz47zcKZDJ1WFhHNW40WGs/edit?usp=sharing

I’ve got an Nvidia GTX660M and 8GB of RAM operating of an i7 intel processor…

Is this scene just too much for the GPU? I can upgrade my RAM to 24GB, - would this be a good idea?

Thanks in advance…
A

Crash on Render is a new feature for 2.69. I am surprised no one else has reported it. I have been noticing it with both Blender Internal and the Cycles render engine. My crash was in a scene with only a SVG import, no large object or particle count.

Here is the work around I have been using, however.

Before you press F12 to render, click the OpenGL render button at the bottom right of the 3D viewport (camera icon). Wait for the OpenGL render to finish then press F12. It works for me but yes it is a hack! (cough)

Thanks Atom. I’m still on 2.68 but will install 2.69 to see if it will help although my gut feeling is it’s a hardware limitation.

Tried the viewport render first, my initial scene renders but as soon as I again increase the emissions or children I get a crash sadly…

Any other thoughts?

I have couple of days old DIY 64 bit blender, 2Gb GTX560, and 5Gb RAM. Here file renders fine in preview and in render window pressing F12.
You could leave textures in - these might be the culprit if they are huge.
http://www.pasteall.org/pic/63067 (just a preview on image)

Thanks eppo, what do you mean by leave textures in?

Before save file click File - External data - Pack into blend. Then other party gets them in blend file; i had to slap on first i had there.

Thanks eppo, wasn’t aware of this. Have amended the google drive blend file to include the textures…

And to clarify it’s once I start increasing the emission number or number of children that the problem occurs, I can render the .blend as it is with CPU or GPU

Just tried your file on different PCs:
On a very low spec netbook (4 GB RAM, Linux Mint 15 x64, Blender 2.69 x64, AMD onboard graphics) the file renders fine in CPU mode, even after increasing the Emission to 4.000 and the Children to 50 for the render.

On my main machine (see signature, Blender 2.69 x64), however, your file crashes immediately after hitting F12 even with your low settings. What helped was switching Render --> Display from “New Window” to “Image Editor”.


The file renders now without crash even with very high settings for the grass. Memory usage stays negligible during the whole render, so that shouldn’t be an issue here.

Nothing crashes here - 12000 particles, same windows config and a lot in the background, including not saved gimp files and another blender instance.

http://www.pasteall.org/pic/63082

Except printscreen lagged during the render.

Hmmm that’s weird. I’ll try rendering to image editor as you suggest and see if that helps.

Is there a way to post / analyse a crash report if the above doesn’t help?

After blender crashes there is blender_crash.txt file in your OS temp folder where ever that happens to be.
Thing is, i can’t say for sure that analysis is possible using this file. I had it where all i could read is log of ordinary editing commands and not a sign of something crashing at all. There could be some cryptic lines like “Error at x06743467 in somefile.exe” which might tell something to devs, not much i assume. Anyways try to see if you have this file; then if you fill in a bug report and attach all the details required you might get developers conclusions.

Have you tried to download, unpack and run fresh blender from builder.org?

Eppo, after switching to the image editor as you suggest in #9 the crash problem seems to be solved so a big thank you! A bit bizarre that this would fix things I would’ve thought but as long as I can keep working, whatever!
A

That goes to IkariShinji ! :yes: He’s on nine…
Anyhow, try fresh blender from builder.blender.org.

Thanks ikarishinji!

I updated to 2.69. Is the blender builder even newer? Ie a beta build?

builder.blender.org - each have time when it’s compiled. Daily, even more than daily.
It used to be build numbers you could easily distinguish and follow what’s exactly new/improved what bugs are ironed out. Since transition to GIT it’s a bit harder to follow: http://lists.blender.org/pipermail/bf-blender-cvs/2013-November/

But are the releases stable or betas?

A lot of things are more ‘stable’ than on ‘official’ release. However nobody gives assurance that something goes wacky during some code update/change. In my experience there were some two or three times things were broken however that’s a matter of day or two. You could use previously normally running version meanwhile since it’s in a separate folder and do not install system wide.