Blender crashes on startup

Here’s another ‘Blender won’t start’-problem.
I got a new pc last week with Vista 64, Phenom X4 9850, Radeon HD4850.
When I start Blender.exe a window appears which says ‘Blender doesn’t work anymore’ (or similar as I have a German version) and it quits. I don’t have any error messages in the command window, the latest driver for my graphics card and all updates for Vista are installed.
I even tried different Blender versions (2.46, 2.45, 2.44 and some from
I have no idea what to do now (except occupying the pc of my husband which runs XP ;))
Any more ideas?

What an incredible feedback :eek:
Just in case someone’s got the same problem, I figured out that it had something to do with my graphics driver. Reinstalled it and it worked.

After a few new restarts it stopped working but now I have the solution for those who have this rare problem too :rolleyes:.
Just copy a dll file from your Blender folder and rename it to atioglxx.dll

i think, this has been discussed before in some threads… Blender (or openGL based softwares) is known to have an issue with ATI.
thanks for the info anyway… :slight_smile:

“”“Just copy a dll file from your Blender folder and rename it to atioglxx.dll”""

Hello, I’m not sure I understand, any dll file from Blender folder to Blender folder ? (like a fake dll to make Blender happy?).

I have similar crashes except Blender loads well but crashes around a minute latter when modeling.

I have a Vista32/E6600/4GoRAM/ATI4850 with the latests drivers catalyst 8.7

What can I do to make Blender stable?


I made a post about this exact issue.
Those visiting this link, please post your replies in this tread.

“Just copy a dll file from your Blender folder and rename it to atioglxx.dll”

What does it mean? I will cry if someone found a fix and then didn’t explain themselfs well enough to help others.

If you’ll read in my thread, I found the same thing. If I reinstall the driver over top of itself then Blender will run until I reboot. It’s a workaround but not a fix. (This is all in Windows Vista 64). It sounds like you may have found a real fix?

There are plenty of tricks to try with ATI cards, many involving older drivers and their dll’s I’ve noticed. However, the HD4850 was released the end of June 2008. The HD4850 is not even 3 months old.

This is a NEW problem, not a “rare problem.” I felt the same way you did, the HD4850 is great, and I thought everyone would have one. But when I asked for help, nobody could help me. Give some time for the card to sink in and others will surely find these thread were creating now much more interesting.

Lastly. Please OP, try to get into particle mode and tell me if Blender crashes. As far as I can tell I’ve over come every problem except for this. As soon as I enter particle mode, Blender crashes, this occures in both Ubuntu and Windows. It’s likely related to the drivers, as I believe both are using the same atioglxx.dll from ATI. Windows reports this as the modual where the crash occured. Ubuntu reports a “Segmentation Fault” in the terminal. Please tell me, with your poorly explained fix, can you get into particle mode?

You may become a hero if you solve future HD4850 issues, as this is sure to become a popular card. It will be a real shame if you did solve the issue but failed to explain yourself clearly.


Ok, to make it clear. There needs to be a file called atioglxx.dll in the Blender directory. What file it is (the content) just seems to be not important. So you could just add a new text file and rename it.

And with “rare problem” I just wanted to express that no one answered and so I got the impression I was the only one with this problem. :wink:

I found the solution on this website

edit: The only ‘problem’ I have right now is that the menus are a bit slow, when they close. But I can live with it.

Yeah, I came across that too.
Does anyone know if those files above (in the wiki he linked to) actually improved the speed of Blender?
I just renamed a blank text file to atioglxx.dll and this is working OK. However, blender is slower, particularly the menus (which really don’t matter). Apparently all we’ve done is disable hardware acceleration. If that’s what’s needed for blender to even run, then so be it, but it would be nice to find some way to gain some hardware acceleration.

Perhaps the Catalyst 8.9 drivers will help?
Catalyst 8.9 makes Blender work as it should, no hastle or workaround. It just works!
See the tread I created above.

Blender crashes for me immediately at startup also (tried 2.46 and 2.47). I have Vista 64-bit, Q6600, HD4850. I tried the “atioglxx.dll” trick and the new ati drivers with catalyst 8.9. Nothing is working for me - it still opens as immediately “not responding.” I’m extremely frustrated - anyone have any ideas?


I have the Catalyst 8.10 now and it still doesn’t work without the trick.
But what puzzles me more is that the new 64bit-version of Blender crashes too at startup and I have the atioglxx.dll file in the directory. I guess I still have to use the 32bit-version :frowning:

Now I have found the real problem behind all the crashs. It was the tool called GamerOSD which came with my Asus graphics card. I deinstalled it, reinstalled the graphics driver and now it works perfect. And also the menu operates smoothly.

I only found this out because Fallout 3 crashed at startup just like Blender.

So all Vista users with an Asus graphic card look for installed Asus tools (SmartDoctor is another one) if your Blender crashes.


 All u have to do is uninstall Quicktime from your system,if it is installed in your system