Blender crashes upon start up (new pc!)

Hello all!

I would greatly appreciate your help! D:

Windows 10 64bit
NVIDIA GeForce GTX 1070
AMD Ryzen 9 3900X 12-Core Processor GHz
64.0 GB RAM
Blender Version 2.93 (newest version), downloaded from (and even tried downloading from Windows app store)

Error Code 3: (subcode 7)
Blender crashing within 2 seconds of starting up program (sometimes it will last 7 seconds, sometimes it won’t even start up. Yes, I’ve uninstalled, reinstalled, restarted computer several times)

Found a bug log that once said: “Ignoring device GeForce GTX 1070, not officially supported yet”

Every other program seems to work fine except for Blender. I found forum threads with a similar problem, but none of the suggestions worked:


  • RAM: Physically taken ram out; rearranged the two sticks/left them out/only one in
  • RAM: Checked BIOS Gigabyte Settings to see if it was enabled/checked RAM Speed
  • NVIDIA Drivers: Installed and reinstalled NVIDIA Drivers, used both studio & game drivers
  • NVIDIA: Tried different settings on the control panel
  • Blender: Installed and reinstalled newest version of Blender (2.93) through the Blender website/App store, older Blender versions/Beta version
  • Blender: Changing Cycles from CPU to GPU compute mode
  • Blender: Preferences; tried different device settings like CUDA, OptiX, CPU only (this was done as fast as I could before it crashed lol)
  • Restart computer: each time I did a change I restarted and even shut down

I was trying to upgrade my old PC to a new PC. Blender worked on my old PC, but it was a bit slow but never crashed. My new/upgraded PC can’t even OPEN Blender without it crashing immediately. How is it that a better, freshly installed PC can’t even open the program and the older PC can?

My older PC specs for comparison:

Windows 10 64bit
NVIDIA GeForce GTX 970
Intel® HD Graphics 3000
Blender Version 2.90 (older)

Thank you kindly for your time!!

Try running blender from the console, the console window should give an error and tell you why it is crashing. Also maybe there is a “crash” text in your temp folder.

To run blender from console:

Thank you for your response!
Unfortunately, I’ve tried running blender using the cmmd prompt and have error logs, one of them saying that the video card was not compatible, which doesn’t make sense, since it’s an upgrade from my old. I uploaded a photo of the error. Not sure if it’s my processor not being compatible with my video driver.

Well it looks like Blender does find your card but for some reason does not like it. I would try to report a bug in or search for related bug reports there. I had a quick look but most of the reports I found were marked as solved, others unrelated.

You have already done many tests, if you are installing the latest drivers for your card, have you tried installing an older driver version? The card has been around for some time so I am sure there are people using it with blender.

I am afraid that the best I can do is wish you luck!

Have you made sure your GPU is configured to Prefer Maximum Performance in driver power management setting?