Blender crashes when FFmpeg output container is AVI


(Gaeriel) #1

Using version 2.79 on Windows 10, whenever Blender uses ffmpeg with an avi-file as output (be it rendering an animation or creating proxies in the VSE), it immediately crashes.

I’m rendering to a Matroska file right now as a workaround, but I don’t think I can choose the container type for proxies, can I?

Either way, Blender shouldn’t crash, so something must be wrong.
I’m quite sure it did work a couple of weeks ago, and I don’t think I installed another program or anything since then, except for the Windows updates. Any idea what could be wrong?

Thanks in advance!


(JA12) #2

https://developer.blender.org/T52692

A developer suspects installed codec pack interfere with the ffmpeg codes that come with Blender


(Gaeriel) #3

yes, I read that, but I didn’t install any codecs between the beginning of December (when it did work) and now.

I checked “Programs and Features” in my control panel, and apparently I did install one thing after the last time it worked, besides updates. I’ll try uninstalling that, although I don’t see how Universe Sandbox could interfere with FFMpeg.

Oh, also, probably a known bug, haven’t checked, but after that matroska-render I remember why I used AVI instead of MKV: Blender makes MKV-files of 1000fps instead of the set framerate.


(Gaeriel) #4

Uninstalling Universe Sandbox, as expected, did not help.
I also tried uninstalling Blender and reinstalling an older version (2.78c), which also crashed.

Let’s try a simple reboot!


(Gaeriel) #5

rebooting wasn’t necessary, closing Waterfox fixed it.
I updated Waterfox to version 56.0.3 and now all seems well.

Still, I wonder what could cause Waterfox to interfere with Blender?


(jensverwiebe) #6

Could be simply a symbol clash, aka both apps use different/incompatible lib versions.
I already proposed in the bugreport to hide those. ( but imho waterfox should do too )

Jens