Blender Crashes when I press "P"


I’ve been discovering a problem that Blender crashes when I press the “P” key in Object Mode to play the game. This happened on Blender v2.74 and v2.75a.

When I press “P,” Blender will load and without even playing the game, it would just automatically close. I checked the code and nothing is making the “P” key close the game.

Another thing I tried was bringing my game to my class and testing it on the desktops they have there. It ran without any problems surprisingly. I think it might be my laptop, Windows 8.1.

Does anyone got any suggestions? I really hope to finish making the game before I end 8th grade so my teacher can try it out (she was a fan of the student project). xD

Shadow Pro

Start Blender from the Console with
blender.exe -d

Then you will be presented with some debug information, maybe you can find the real Problem then.


So I ran “cd c:\Program Files\Blender Foundation\Blender” and then “blender.exe” After Blender loaded up, I opened my file and pressed “P.”

The error is, “ERROR: EXCEPTION_ACCESS_VIOLATION” What does that mean and how can I fix it?

Shadow Pro

You forgot -d after blender.exe, so it doesn’t show really much info.

I have now added the -d to blender.exe This is what it shows. What does it mean and is it possible to fix it? If so, how can I?

Shadow Pro