Blender crashes when rendering SSS and Hair

Hey guys,

Blender is being mean to me today. When I’m trying to make a render of my BL2 entry with SSS on and a Hair Particle System it crashes. Blender has no issues rendering hair or SSS separately. Is there an easy fix for this? (I’m using 3 SSS passes and 15000 hair particles)

Machine specs (shouldn’t be the issue here I think):
OSX 10.5.8, 2 x 2.8GHz Quadcore, 10.8 GB memory, GTX285 video card, Blender 2.48 and 2.49b.

EDIT: Tried a different material (without SSS) and it still crashes… A cube, however, renders over 50K particles with ease.

Is it possible to see any messages in the Console? Or is it a hard crash? Anything about Segfault?

Don’t know where to find app crash logs in Mac, but they could help.



Thanks for your reply Fligh. I got a buttload of errors in my console. I have no idea which of these are useful, so I’ve included the entire log. These two popped out to me though:

Mar 27 23:10:17 patrick-boelenss-mac-pro [0x0-0x50050].org.blenderfoundation.blender[58354]: Calloc returns nill: len=14737408 in ParticleCacheKey, total 3110056500
Mar 27 23:10:23 patrick-boelenss-mac-pro[1573] ([0x0-0x50050].org.blenderfoundation.blender[58354]): Exited abnormally: Bus error

Complete log:

EDIT: I figured out the problem. Turns out I didn’t save when I though I did, resulting in 20 children per particle (15.000 x 20 = 300.000 hair strands). Still not a -whole- lot, but probably more than I’ll need. :wink: Sorry for the hassle!