Blender crashes when rendering

I’m having a frustrating problem with Blender. Every time I run it, I can render an image once but the program will, without fail, crash if I try to render an image a second time. A dialogue box shows up with an unhandled win32 exception. I just switched over to Blender 2.49, which makes me wonder if that is responsible for the error, as I did not get it when I was using 2.48. Any advice?

Does it show any errors in the console window?

Yes, sorry I didn’t mention that. It says, “Calloc returns nill: len 38352384 in CDNormal, total 604022336”

The only thing I can find is this. Its old but any help?


Ah, I bet that’s it. Because I found that when I reduced the subsurf level on rendering it stopped having trouble. I guess my vertex count was taking up too much memory to render twice or something. Still seems odd, though, that it would work once and then crash the second time through. Oh well.

Yeah, I had that same error when I tried to render one of the big buck bunny scenes with grass in it, lol.

Lol. Hey, while I’m on the subject of rendering, I think I’ll throw in another question. Does anyone have any idea why when I render I get the wrong color on certain parts of the model? I used a UV map and everything works perfectly except for a small smudge on the head of my character with the color from my character’s gloves. I’ve looked over the UV map and it seems to be layed out correctly. Any ideas or do you think I just set it up wrong?

Not sure, just by the description…
A .blend may help?

Good point. I’ve been looking at this and finally realized that the smudge I was seeing was actually my UV map image pasted on to the individual faces in a couple of places. Do you think this is a bug or do you think I might have made the mistake? Here are some pictures of the UVmap and rendered image, I’ll try to reduce the size of the .blend file (bit too large) and see if I can send that as well.


Did you try the “compress file” option in the file menu?
You can upload to a file hosting site such as if you need to.
(I don’t see any problems so far, by the way;))

Thanks for the help. You can download my .blend file here:

I look forward to your reply. Thanks.

Hmm… My web protection blocks that website.
I believe mediafire, or cdupload work though…

cdupload is giving me trouble when I try to register. I just uploaded it to mediafire, though, here’s the link:

Lol, I am such an idiot. Someone else just pointed out to me that the troublesome faces are not included in my original unwrap (I’m not sure why) which means they are getting the UV map applied to them individually. Thanks for your time and efforts, I appreciate it!

Sorry I didn’t reply sooner, but our internet went down during a small storm here.
It went down right as I was hitting the post quick reply button to this thread!
(It’s back up now though.:wink:

Glad to hear you’re back. Thanks for all your help with my troubles. Happy blendering!