Blender crashes whenever a window is closed

I was going to report this as a bug, but thought better of it. There is clearly something wrong with my specific system. I’ll present the problem here formatted like a bug report:

System Information
Operating system:Windows 10
Graphics card(s): ZOTAC Trinity RTX 3080, Dell (Alienware?) RTX 2080ti. GIGABYTE Windforce RTX 2070 (Driver version 472.47, tested with each card individually)
CPU: Threadripper 1950x (underclocked due to stability issues at stock clock)
Memory: 32GB (4x8GB) / 48GB (2x16GB + 2x8GB)

Apologies for the verbose system description, but at this point I feel like anything could be the culprit

Blender Version
Broken: 2.81, 2.92, 2.93

Short description of error
Blender crashes whenever a window/dialogue box is closed. This includes when clicking “save as” in the save as window, importing, appending and linking, exporting. Dragging and dropping files into blender, however, works perfectly fine, as does opening files from windows explorer or the recent files menu, and saving by ctrl+s. I have cleared my preferences and done a clean install of blender.

Exact steps for others to reproduce the error
As far as I know, no-one else could possibly recreate this problem or they would have already posted about it. It is not file-specific at all. To make blender crash all I have to do is open the program (default scene), file → open, just click cancel, and everything closes immediately. In leiu of that, here is a crash report:

BD02 Main Art.crash.txt (49.7 KB)

The exception code is EXCEPTION_ACCESS_VIOLATION, and it seems to be related to blender calling ‘disposeWindow’ and win32’s “NtUserDestroyWindow”.

I do not have any stability problems with any other apps on my system, let alone anything like this. I’m also able to open all my files and they work as normal from blender on my macbook (over the network). Does anyone have any idea what could possibly be going on? I’m open to literally any suggestions at this point, or if there’s anything I’ve missed.

one final thought, I suspect wiping the entire OS and doing a clean install of win10 would probably solve the problem. Before I resort to that, are there maybe permissions files somewhere that might have become corrupted? Like, win10 won’t let blender close its windows, and that’s why it crashes? That certainly gels with the exception code.

I never understood why someone would reinstall his entire OS for one app… then this OS is… okay no flamewars…

  • Blender is downloaded from blender.org ?
  • (on Win) Used installer and/or portable zip ? (Did you mixed them?)
  • You know where the configs are (and can backup them and delete them on the computer to have a fresh install for blender)

So i hope someone on win can help more. I’m on linux …

Yes, each version of blender I have currently installed was downloaded from the official blender.org distribution, including alpha versions. I’ve used the full installer every time. I’ve also tried completely removing all versions, preferences and all other files from roaming and doing a clean install. No change in symptoms.

I’ll try it with a portable zip and get back to you tomorrow.

Just to confirm, I also get this behaviour with a portable version of blender. If anyone has any ideas please let me know.

Another update, I am not getting this behaviour in blender 3.0

It has briefly gone away and come back in the past, but for now I will mark the topic as solved.

Are you using (or at least have connected) a tablet device? The stuff in the crash report suggests that might be where the problem lies. Could still be a Blender bug. Maybe update your Intuos (or whatever) drivers, or try disconnecting/disabling the tablet device if it reoccurs and see if that affects it.

Aha! this sounds like exactly the kind of thing that might cause it - yes, I usually have a wacom tablet or two connected to my pc at all times. I will run some tests and get back to you.