Blender crashes whenever I go into edit mode.

I’m making some models for a game, and I’m hoping to make them low poly (like Nintendo 64 low-poly), and I’ve learned that you can use the “Decimate” modifier to do just that, but once I apply the modifier (usually within a range of 0.10 - 0.30), and go into edit mode, the game crashes, every time, maybe once in a blue moon, it won’t crash.

It’s not just for that particular model, it happens every time I do it, regardless of the model, or ratio.

What causes this and are they any solutions? I hope to get an answer soon, because I’m about to tear out my hair at this point, knowing I can’t continue making the models, and the game!

Just tried with the Standford Thai statue (69 000 000 triangles) and it worked with no problem!

What version of Blender are You running?

2.64, I think that’s the latest one, although the Blender site seems to be down (I can’t get on it), so I can’t check.

Latest is 2.64a.

Maybe one of your models is corrupted, has faulty structure, like stray vertices that makes the modifier crash.

I remember reading about a way or script to find these, maybe You could have a go at that!