Blender crashing on startup 2.90 and 2,91

$ ./blender
found bundled python: /home/homedir/Downloads/blender-2.91.0-linux64/2.91/python
ERROR (gpu.shader): OVERLAY_shader_outline_prepass_pointcloud_1207 Linking:
|
| Error: Input block `ShaderStageInterface’ is not an output of the previous stage

Writing: /tmp/blender.crash.txt
Segmentation fault

crash.txt

Blender 2.91.0, Commit date: 2020-11-25 08:34, Hash 0f45cab862b8

backtrace

./blender(BLI_system_backtrace+0x20) [0x84ba490]
./blender() [0xe5293a]
/lib/x86_64-linux-gnu/libc.so.6(+0x354c0) [0x7f3ec68f04c0]
./blender(GPU_shader_get_builtin_block+0) [0x70a85a0]
./blender() [0x1314c06]
./blender(DRW_shgroup_create+0x1d) [0x131696d]
./blender(OVERLAY_outline_cache_init+0xce) [0x134d74e]
./blender() [0x1343855]
./blender() [0x1310c76]
./blender(DRW_draw_render_loop_ex+0x2c4) [0x1312294]
./blender(view3d_main_region_draw+0x8f) [0x1afb15f]
./blender(ED_region_do_draw+0x7e1) [0x16b43f1]
./blender(wm_draw_update+0x52e) [0x11c181e]
./blender(WM_main+0x30) [0x11bf740]
./blender(main+0x30d) [0xd8d12d]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f3ec68db840]
./blender() [0xe4f0b3]

Python backtrace

Hi. Did the problem start to occur suddenly having been able to use 2.90 / 2.91 versions before? Or did the problem occur from the first time you tried to test those versions?
If it is the first thing I asked, you try renaming “2.90” or “2.91” folder in /home/YOUR_USER/.config/blender

and you avoid copying settings from previous versions if Blender manages to open

The problem happened suddenly. I was previously using 2.90 for awhile without problem. I think I did recently re-save my startup file.

2.83 works fine. But 2.90 and 2.91 both kind of start to open and you sort of see the main window fire up, but real quick it dies. I never even see the welcome screen.

I tried renaming the .config directory, same problem…

Just in case, “2.90” or “2.91” folders inside “.config” > “blender” folder were the ones to rename. No the “.config” folder, because you could lose the settings of other programs.

The problem is weird. You are using Blender official versions downloaded from the Blender website, right?

If so and you are not having problems with graphics drivers, you should report the problem to developer.blender.org to see if they can better tell you what the problem could be.

Yeah, I changed just the 2.91 name inside .config. I even tried copying the contents of 2.83 into 2,91, nothing. I don’t really see anyone else with the issue…

Hi. If you report the problem, after logging in to the previous site that I mentioned, you do it from Blender 2.8 > Help menu and report a bug. That will collect information about your hardware. But you later clarify by editing the report that the versions that do not work are 2.90 / 2.91
What is the output you get with the following order from terminal?
sudo lshw -c video

Ok, thanks, I will do that. I’m away now. I did an apt update and upgrade last night, but same problem. I recently installed a bunch of gtk3 stuff for glade.

If you are using Blender installed from Ubuntu repositories or PPA, running blender from the terminal can give some clue to the problem in the message that it returns, by writing:
blender

Anyway, it is always advisable to use Blender downloaded from the official site, extract the package to a new folder, enter the folder and there double click on “blender” file.
https://www.blender.org/download/

I almost never use ppas. Never for blender. I get stable releases and extract them.

This is the info from lshw

sudo lshw -c video
[sudo] password for username:
*-display
description: VGA compatible controller
product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: [email protected]:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:29 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)

There it indicates that the system is using an integrated intel GPU. Don’t you have an nvidia / ATI card?
I ask just in case, there are occasions that the user think that the system is using a dedicated graphics card when in reality the system is using an integrated GPU.

So if you only have an integrated Intel GPU, chances are high that it is a bad Mesa driver. But to know exactly what the problem is then you will have to report the problem to Blender developers and follow the steps that they indicate to obtain more information about the problem and your system.

Edit:
Are you using an old version of Ubuntu?
Here’s some users with a similar problem using Ubuntu 16.04 and intel iGPU:

Short answer, right now I am using the on board VGA.

I previously had a GTX 780 but it died, or so I thought. I only have 2 PCIe slots, and only one of them has enough MOBO space behind it for a 780. One day (like a year ago) I woke up and my computer would not boot. I eventually figured out that if my GTX was inserted it bricked my machine, both as primary display or secondary. I had been using it as secondary using it mostly for cycles renders and machine learning. So I pulled it, and just used the on board vga and my i5 CPU.

Now 2 days ago, I am having problems with dropped packets (I have a PCIe wifi card) and I decided to switch the slot it’s in, to the slot I used to have the GTX in. My machine bricks, won’t boot. So somehow inserting any card into that PCIe slot causes major problems. The only good thing is that, hey, maybe my GTX 780 is fine, I just have a bad slot. I’ve never really seen that happen. SO I put the wifi card back in the original slot and it works. It was right around this time frame that blender won’t start. BUt truthfully I think it has more to do with GTK3 updates and maybe even python 3.6 that I installed.

And yes, it’s an old 18.1 Serena Mint. My “update manager” which is supposed to be the way to upgrade distro version, will not open either, also new problem. So I have been tearing apart my garage looking for the dusty old GTX 780, and I may take a mitre chop saw to my computer case and make more room. I’ll probably just wind up saving my data somewhere and installing Ulyana and just having a clean install. But I’d rather not.

Also yes, there seem to be others with this problem.

Hi.
Other users have mentioned that they have been able to solve the intel problem in Ubuntu 16.04 by updating the Mesa drivers from this repository PPA (Add the PPA repository, update and upgrade):

https://blenderartists.org/t/blender-2-9-wont-start-linux-mint-tara/1251049/11

Thanks.
I tried, it gets partway through the updates and stops, complaining about the key and that it can’t find certain files. I can’t even open my update manager, when I try to open it on a shell $mintupdate it lists errors regarding gtk3 css files. I’m reaching the point where it’s easier and faster to just backup what little data was on the OS drive (I have a separate data drive) and install a new OS. Do you use linux? if so which distro?

Did you have pakage problems before adding that PPA? Or did the problems appear after adding the PPA?
If the problem was caused by this PPA, you could try ppa purge that PPA. Being connected to the internet and from the terminal, these two things:

sudo aptitude install ppa-purge

sudo ppa-purge ppa:ubuntu-x-swat/updates

To make a backup of your files you must copy the whole folder “/home/YOUR_USER” to another location. For example, open your file explorer in “/home”. Right click on “YOUR_USER” folder and select “Copy”. Then paste the content to another disk making sure you have available space. After making the backup you will have all the files that you had in /home/YOUR_USER, and also the configuration files of all the programs in the hidden folders that start with a “.”, for example for firefox "/home/YOUR_USER/.mozilla/. But It is convenient for you to also manually backup your web browser’s bookmarks.

I use Linux, now I am using KDE Neon User Edition. It is based on Kubuntu, but with updated KDE packages.