Blender crashing on startup

Hey guys, I just recently bought a new computer as i was due for an upgrade. Of course one of the first things I installed was blender! Only problem is it won’t start :frowning: Everytime I try to start blender it crashes. It seems to be some problem with a file called msvcr120.dll. I did some research and it seems to be a common problem. Funnily enough i tried installing the 32 bit version of blender and it works fine. Obviously i’d rather be running in 64 bit so blender can make full use of my hardware. Anyways I thought I would just post here and see if anyone knows a solution to this problem. Specs below…

OS: Windows 7 64 bit
CPU: AMD 8370 4.3 ghz (8 core)
RAM: 16 GB’s DDR3 Ram
GPU: Radeon R9 270
HDD: 2 TB Western Digital
PSU: 750 Watts

I have been having the same issue. here is a build of it that worked for me:
If the install doesnt work you should be able to run it from the zip folder.

That msvcr120.dll error indicates that you did not install the correct version of the Visual C++ Redistributable Package. Blender 2.71 and up use another (a newer) compiler, so you will now need the 2013 version and not 2010.

There is a corresponding hint and link on the website. Unfortunately there seems to be a bug in the website code that stops that part of the page from being displayed initially:

After a page reload it suddenly appears:

Yeah I’ve installed visual c++ 2013. oddly the 32 bit version of 2.72 works no problem so I’m not sure whats causing the crash :S