Blender crashing when switching to particle edit mode

I can’t seem to find if this is a known problem in 2.71. I have a basic hair particle system with some wind force added. As a test to follow the wiki steps in editing the particles, I baked a 15 frame animation. Then following the steps in the wiki, it says to switch to particle edit mode to edit the particles. (Want to fix or adjust a few frames where hair penetrates mesh). When I switch to edit the baked particles blender crashes every time. I restarted my computer as well, but this didn’t fix the problem. I am on a Mac with OS10.9. It is not baked to a disk cache either. Has anyone else experienced or heard of this issue? Is there a way to fix it? The rest of this particular blend file is fairly large, I am hoping I don’t have to attach the file. Tho if needed I suppose I could append the particular object to its own file. Any help or advice would be appreciated. Thanks.

Hi, try to append the object with the particle system and the windforce to a new file.
Easiest way is to group the objects and append the group.
If the problem still happen upload this new file, if not it is something else in your file.
You can append object after object to verify wich make trouble.
It is a bit inconvenient but sometimes the only way to sort it out.

Cheers, mib

Thanks for the quick reply. I’ve been playing with weight painting and tweaking the wind force settings. Now the hair only penetrates the mesh in a few small areas. I plan on animating the camera movement too, so maybe I can adjust the angles to hide these areas. I so wish there was a simple way to edit the hair sim frames. A few fixes here and there and it would be perfect. I’ll have to try what the wiki says with a fresh blend file. I’m not even sure if it’s possible, I had been hoping to find out until I had the crash issue. Thanks again for the advice.

I also have this problem, also 2.71 and when I change to particle edit mode it crashes.

Ok, I figured out it’s my scalp head hair particles causing a crashes. If i disconnect hair, I can see particle edit mode and when I connect - crash. Something is wrong with hair particles options.

Try a daily build from https://builder.blender.org/download/
May it is fixed until 2.71.
If not post bugreport with your file.

Cheers, mib

I think I repaired it by trying everything: It seems to be some kind of Hair dynamics bug.

My solution is:

  1. disable Hair dynamics
  2. Switch to edit particle mode
  3. Enable Hair dynamics

Now, everything should be ok and work perfectly.

However I’ll still check that build, thanks mib (cheers from Stettin, really close!)