Blender CVS daily checkout down?

Is anyone else not able to access the source through http://, because the directory is emptpy, but it was there fifteen minutes ago. thanks…

u got a comma after the http://

I wasn’t posting a link, I was stating a fact, I didn’t try to do it throug toroiseCVS, I tried to do it from however, I now notice after going there to get the URL that the file is back, was it down for updating or something because before it was the 1-23-07 source, now it’s the 1-24-07.
EDIT: that could make sense if the time difference is so great from here (wisconsin) and the netherlands (or wherever it’s being uploaded from) so that it says that it was uploaded at 00:28

Maybe a ressource friendly script that first deletes the old file and then uploads the new checkout :slight_smile:
But if you need recent checkouts that badly, why not use cvs directly? Saves a lot of megabytes when updating an older checkout instead of re-downloading the whole source tree…

Way faster too.

The reason I don’t do it from CVS, is because the computer I compile blender on doesn’t have an internet connection, so I download it from the local library’s computer (I’m not going to install tortoisCVS onto a library computer)

ha, yes, not a good idea. Library computer explains a lot. Is the repository back up yet?

Here’s a thought. There’s a DOS version of CVS that works exactly like the Linux version. Put the DOS exe on a floppy and download to the same place you download the zip. Kind of a lot of work I guess. I have that right here. I wonder if Tortoise can be executed from the command line. . . Or, if tortois can be installed on a CD ooh ooh:cool: I guess that zip file looks pretty good.

I download to my thumb drive, and I could install tortoiseCVS onto it, but the command line won’t navigate to the F drive. Also, not sure if tortoiseCVS would fit on a floppy disk. Unless, is there a gnuwin32 cvs.exe?

also something I just thought of, does downloading from cvs download the *.tar, or the directories within the *.tar. Because my thumb drive is 256 mb and it wouldn’t fit all the directories
with the batch file

cd cygwin\home\mame
cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co blender


cd cygwin\home\mame
cvs -z3 -d:pserver:anon[email protected]:/cvsroot/bf-blender co lib/windows

or some such

It downloads the files directly, no compression. If you format your drive as a compressed drive you may be able to fit everything in there. That would be the way to go for compession, imo

All right, apologies for anything I’m about to say. These forums are so difficult.:o

This is probably out of the range of the forum in general but for the thread is on target. (apology 1

dreblen, you’ve probably already tried but this is really bothering me. If you’re copying files to your thumb drive then the dos command prompt will be able to see it as well. If F: is missing then the thumb drive will be a different letter. Try E:, D:, etc. until you see your files. (apology 2

The reason you want to use CVS, as mentioned before, is that you only have to download the files that have changed since the last time you checked out. When you download with CVS you will want to send the files to your thumb drive and then leave them there. Then the next time you check out it’ll take about a minute. If you build elsewhere then you should need to do a ‘make clean’ almost never (or whatever build system you’re using).You already knew that. (apology 3

Thanks for letting me rant. Not really a rant but if you want more? No, stop talking now. It’s annoying. :stuck_out_tongue:

Okay, It did navigate to the F:\ drive, but I had to do cd F:\library\kubuntu\18.gif to make it switch to the F drive.