Blender Cycles AMD Opencl It's possible working now.

(Sdar) #1

#############UPDATE############
Try to use the latest drivers to get best results.

The latest driver atm (September 15) is:
Amd 13.10 Beta Driver you could find it here:

##############################

I’m doing some testing right now but with the new AMD Catalyst OpenGL 4.3 beta driver for Windows 8.1, installed clean in a windows 8 (disabling driver signature) the Cycles kernel compiled successfully in around 5 minutes.

Specs:
Intel qx6700 @3.6
8Gb ddr2
Amd 7950 3gb gddr5
Windows 8

Blender 2.68a 64bit

How to:
Driver:

Clean old drivers with driver sweeper (Alternatives: Atiman Uninstaller, Driver fusion)
use CCleaner after driver sweeper to clean any remaining entries in the registry.

Reboot

Install new driver (I used this driver)

reboot again.

Blender:
Win + R type CMD press enter
go to your blender folder. ex: Cd C:\Program Files\Blender Foundation\Blender

press enter and then type: set CYCLES_OPENCL_TEST=all

And now: start blender.exe

Inside blender go to File -> User preferences -> System

Under compute device select OpenCL and then Tahiti.

Close the preferences windows and go to the render panel and select device: GPU Compute.

Close all unnecessary programs to release some memory and try to render something, the first time it’ll take ~5 minutes you can check in the log window if the build has succeed.

The first time i tried my pc crash so take care not to lose something.

EDIT: Well it works fine in pretty basic scenes however there’s some glitches in more complex scenes:


BMW-MikePan scene 128 samples 8 Minutes Gpu only (AMD 7590) i expected more speed but it’s a beta driver so hopefully we can see a fully functional one before the end of summer.

EDIT:
I don’t have enough posts yet so my replies are going moderated so it’ll be a little delay in my replies.

YAFU: If i had enough time i’ll try to test it in linux but i’m messing around with wayland so i have to do a fresh install first and i don’t have too much spare time.

To the forum: I hope that using edit for reply wasn’t against any rule in the forum, i know that is not the correct way to do things and i’m sorry but i don’t know if i’ll have enough time to reply tomorrow.

Anyhow everyone have enough information to try this by himself now so it’ll be interesting to know what gpus are capable to run cycles and if it would have artifacts like my 7950 cause it could be OC related.

0 Likes

(tolga9009) #2

Thanks for sharing! I wanted to reinstall Windows 8 tonight anyways. I’ll try it with my HD7970 and share my results! If this really works for me, I’m probably going to cry :)!

Edit: The most important fact is, that it successfully builds with the AMD compiler. OpenCL support was halted and not beeing worked on due to limitations. It was likely for bugs to appear. Now, the Devs can finally go forward and improve OpenCL code!

0 Likes

(Sdar) #3

Sadly i posted before a more toughly testing (The default cube) and i didn’t see the artifacts till i’ve already posted so i have to wait till the post was moderated to edit and post a more detailed status.

Be sure to disable driver signature (I’m not sure if do you need to do it in this driver in particular but it’s probably needed).

To disable driver signature:

(You can google it and you’ll found explanations with images but i’ll try to explain how to disable it)
You must go to the right windows bar hit settings and at the bottom change PC settings go to General and at the bottom under the Advanced startup section you’ll have a restart button when your pc is restarting you must chose troubleshot -> Advanced options -> Startup settings then you must press restart again and then you’ll have a window with the diferent startup options chose the Disable driver signature option (I’m pretty sure is option number 7) now you can install not signed drivers.

0 Likes

(English is not my native language) #4

Are you the same Sdar that I’ve read on Phoronix, right?
What about this in GNU/Linux?

0 Likes

(Zodiark1593) #5

Hmm, wonder how a Mobility Radeon 5470 would compare with a Core i5-460M @ 2.53 GHz. Ehh, better stick with the cpu for me.

0 Likes

(Sdar) #6

Small vid:

It’s not as faster at it’ll be but it’s working :slight_smile:

0 Likes

(Sdar) #7

I’m a little lost now, fresh ubuntu 13.04 the drivers are ok and i installed manually the icd from the driver and the ocl headers.

I’m using the following method to start blender with ocl support:

cd /opt/blender
export CYCLES_OPENCL_TEST=all
./blender

But i can’t see the opencl option under the system tab :S

Has someone know what’s the right way to test blender ocl under linux?

0 Likes

(Jaxom191) #8

Tested with the these Drivers on a sapphire Toxic 7970 6gb. works but yes i see the the graphic glitch in the shadows of the render. and a not I don’t think Cycles is detecting the cards compute units correctly for the full render. ie-F12, seems to only render one tile at a time. rendered view is nice and fast though.

test time of normal start up cube CPU amd FX-8150, 100 samples-time=22.52sec GPU HD7970- time=3.09sec.

0 Likes

(English is not my native language) #9

I do not have an ATI, but apparently in Ubuntu all files for OpenCL (GPU) are included in the proprietary driver package. You need to install the fglrx driver (Catalyst). Uninstall everything you have installed so far regarding OpenCL or fglrx. Download from Xorg Edgers PPA resents version to fglrx drivers, preferably beta. Please do not add this PPA in your system, is unstable. Download only packages corresponding to the driver in a folder (13.150 beta):
https://launchpad.net/~xorg-edgers/+archive/ppa/+sourcepub/3386364/+listing-archive-extra
for example for amd64 architecture:
fglrx-amdcccle_13.150~beta-0ubuntu1~xedgers~raring1_amd64.deb
fglrx_13.150~beta-0ubuntu1~xedgers~raring1_amd64.deb
Then open the terminal on that path to where you downloaded the two files and install with:

sudo dpkg -i *.deb

Restart the system.
I repeat, I do not know much about OpenCL on ATI, but you could try that.
It would be better than you try a new Blender build, download, extract and run blender from this folder with:

CYCLES_OPENCL_TEST=all ./blender

http://builder.blender.org/download

0 Likes

(tolga9009) #10

I’ve just tested this on my Setup and it’s really working (Windows 8 non-Preview + AMD OpenGL 4.3 Beta Drivers)! Kernel compilations takes a long time and eats up 6 - 7 GB of RAM (luckily, I have 16GB). Actually, when you run the render a second time, render times will be faster, because the kernel just needs to be compiled the first time. At first, my HD7970 performed quite bad. Then I adjusted the Tile size to 512 x 512, which fully utilized my HD7970! RAM usage on my PC was about 2GB, CPU usage about 10%, GPU RAM usage about 1.3GB and GPU utilization constantly 99%. The rendering speed on GPU only was about 02:30mins, OpenCL on CPU only took a bit longer (Intel Xeon E3-1245v2). However, the GPU output has artifacts!

Still, OpenCL supports was halted. Cycles finally runs on AMD hardware! The Devs can finally work on improving OpenCL code and fixing bugs! This was a very important step!

//Edit: Haha, 1337MB RAM :)!

//Edit 2: Artifacts are not OC related. I’ve run the test now on stock speeds and there are the same artifacts.

//Edit 3: Choosing “CPU + Tahiti” as computing devices will make Blender crash at kernel compilation. Only CPU or GPU works at one time.

Attachments


0 Likes

(Sdar) #11

Ok i can confirm that it’s working on linux too.

I thought i might be installed something wrong cause is not working every time i opened blender… just works sometimes … but when it works it seems to work a little faster than the windows implementation.

0 Likes

(doublebishop) #12

This is great news… can anyone render the same image via opencl on the cpu to see if it is a opencl coding artifact problem or a amd driver artifact problem.

0 Likes

(tolga9009) #13

OpenCL on CPU works like a charm. No artifacts; it looks exactly like native Cycles on CPU (but is a bit slower). It’s also possible to render hair on OpenCL CPU; on AMD OpenCL it’s not. So, next step would be to find out, if these problems also occur on Nvidia OpenCL; so we can find out, if this is related to Blender’s OpenCL GPU code or to AMD’s OpenCL implementation.

0 Likes

(English is not my native language) #14

As I have already said, I have no AMD components. I have the curiosity to know what you need install to have available CPU OpenCL for AMD processor?
I understand that in the OpenCL configuration window in Blender, GPU OpenCL implementation shows as transistor technology used (Cedar, Tahiti, etc.). How is shown the OpenCL implementation for AMD CPU in this configuration dialogue? (screenshots are welcome)

0 Likes

(Sdar) #15

I suppose you need the Amd opencl cid… try installing the latest opencl app sdk, it probably should work that way.

The CPU then should be displayed like my intel proccesor in the video that i posted above (second 31) btw i don’t know why my intel was shown like an OpenCL device when my core 2 quad is not OpenCL capable.

0 Likes

(zeealpal) #16

Both Intel and AMD have OpenCL CPU drivers that allow you to run opencl on any cpu (somewhat recent)

I’ve found that one of AMD/Intel’s OpenCL CPU (not sure which) takes 23seconds, white the other takes 15sec to render a test scene. Native CPU takes 22sec.

0 Likes

(tolga9009) #17

Is there any way, we can help improving AMD / OpenCL Support? I’m currently testing out Windows 7 Professional N x64 with those OpenGL 4.3 Beta Drivers and will report asap. Eventhough I’m not a Dev, I can apply patches and build Blender, if there is any need for help.

Also, could someone with an Nvidia card test, if those artifacts also appear on their Render (ofcourse running with OpenCL instead of CUDA) or if this is limited to AMD graphics cards only.

0 Likes

(English is not my native language) #18

tolga9009, You can read this thread where are developers discussing. By the way, “storm_st” does not seem very optimistic …
http://www.blenderartists.org/forum/showthread.php?254521-A-good-news-for-AMD-ATI-Graphic-cards-owners/page40

Nvidia and intel works well. With nvidia there are different kind of artifacts, usually only the first render. But then the end result is perfect. With Intel OpenCL works perfect:
http://www.blenderartists.org/forum/showthread.php?300561-Testing-Cycles-with-OpenCL-on-GNU-Linux-(Intel-nVidia-and-maybe-ATI

0 Likes

(tolga9009) #19

Thank you YAFU for the links! Feel kinda sad now :(…

I’ve just tested the OpenGL 4.3 Beta Driver (Windows 8.1 Preview Driver) under Windows 7 x64 and it also worked (again, with the same artifacts). While building the kernel, it took up to 10GB of my RAM; still, it compiled! Just for more testing, I’ve wiped the OpenGL 4.3 Beta Driver and installed the 13.8 Beta Driver (released on 1th August), enabling full OpenGL 4.3 support. With this release, it doesn’t work. Kernel compilation fails with Error code “E103: Insufficient Private Resources”. So, it’s a step back again (or simply, the latest changes to OpenCL support weren’t merged to this driver). I’ve to check the OpenCL 2.0 Preview Driver now.

0 Likes

(Andrew Gacia) #20

i’ve done the tutorial on the thread

but i face this, im going crazy on this OpenCL AMD

specs
Intel i3 2120 @3.3Ghz
8GB of RAM
AMD RADEON HD 5500
Win7 Ultimate x64
blender 2.68a x64

0 Likes