Blender cycles crashes on attempting to render textured surfaces

Every-time I try to apply an image texture to a surface, blender crashes without error messages or warnings.

I’m running Arch Linux with Xfce, I seem to remember it working on my previous OS of Linux Mint, but I haven’t rendered for a while and I’m not sure if I fudged a setting or something.

I have tried it on quite a few versions of blender, I can’t get the 32bit versions to run though.

this is the terminal error:

terminate called after throwing an instance of ‘std::runtime_error’
what(): locale::facet::_S_create_c_locale name not valid


  • edit /etc/locale.gen as root
  • delete ‘#’ before “en_US.UTF-8 UTF8” line
  • save & quit
  • run “locale-gen” as root
  • render

luckily team fortress 2 had a similar problem to this and i solved it, damn strange that your selection of language will crash blender, but yes it will.

Hi, could you try with daily build from
I think they have fix it for 2.69, but if not may report to bugtracker.
It would be helpful for other Arch user.

Cheers, mib.