Blender Cycles Fluids

I made the Cylinder as an obstacle but the water seems to be visible through the obstacle. It still stops the water from passing though but it is seen through the cylinder. Any advice on how to stop this from happening would be greatly appreciated :slight_smile:

A higher-resolution simulation might fix it. You could add a bit of thickness to the cylinder.

To clarify, adding thickness to the cylinder won’t fix the intersection, but it will hide the fact that it’s happening.

hmmm, the resolution of it is 150, the domain size is 1. For the cylinder i had extruded it, afterwards the fluid seemed to pass the first layer (inside layer) and show itself on the outside again :frowning:

What setting for Volume Initialization have you used for the cylinder? I had a similar setup to yours in a test I was doing and achieved the best results with “Both” instead of choosing “Volume” or “Shell”.

Daemonicus the volume Initialization is set to “Shell”. I’ll change it to “Both” and have a look.